summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPu Anlai2020-05-12 19:59:15 +0200
committerPu Anlai2020-05-12 19:59:15 +0200
commitd38f62fa6fdbc0b4efec4063fc47b6bcfcc01308 (patch)
tree5ac99eb1ece82679cc39f6d98458829f0e41560a
downloadaur-d38f62fa6fdbc0b4efec4063fc47b6bcfcc01308.tar.gz
First package release
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD47
-rw-r--r--psychonauts-gog.desktop10
-rw-r--r--psychonauts-gog.sh3
4 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c5ea3fc930c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = psychonauts-gog
+ pkgdesc = A platforming game by Double Fine Productions (GOG version)
+ pkgver = 2.0.0.4
+ pkgrel = 1
+ url = https://www.gog.com/game/psychonauts
+ arch = x86_64
+ license = custom: commercial
+ makedepends = unzip
+ depends = lib32-sdl
+ depends = lib32-openal
+ depends = lib32-gcc-libs
+ depends = lib32-glibc
+ conflicts = psychonauts
+ source = psychonauts-gog.desktop
+ source = psychonauts-gog.sh
+ source = gog_psychonauts_2.0.0.4.sh::gog://gog_psychonauts_2.0.0.4.sh
+ md5sums = a4d91ef0270b1734338252c928f59354
+ md5sums = ab9c3c8d8ba61e9c1be6feefe9ad18db
+ md5sums = 7fc85f71494ff5d37940e9971c0b0c55
+
+pkgname = psychonauts-gog
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa8714de7f46
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Nicolai.Pudimat <$maintainer@aol.de>
+pkgname=psychonauts-gog
+pkgver=2.0.0.4
+pkgrel=1
+pkgdesc="A platforming game by Double Fine Productions (GOG version)"
+conflicts=('psychonauts')
+arch=('x86_64')
+url="https://www.gog.com/game/psychonauts"
+license=('custom: commercial')
+depends=('lib32-sdl' 'lib32-openal' 'lib32-gcc-libs' 'lib32-glibc')
+makedepends=('unzip')
+source=("psychonauts-gog.desktop"
+ "psychonauts-gog.sh"
+ "gog_psychonauts_$pkgver.sh::gog://gog_psychonauts_$pkgver.sh")
+md5sums=('a4d91ef0270b1734338252c928f59354'
+ 'ab9c3c8d8ba61e9c1be6feefe9ad18db'
+ '7fc85f71494ff5d37940e9971c0b0c55')
+
+DLAGENTS+=("gog::/usr/bin/perl -E print\(\"${RED}\"\ .\ substr\(\"%u\",\ 6\)\ .\ \"\ not\ found.\ \ Please\ download\ the\ file\ off\ gog.com\ and\ put\ it\ in\ this\ directory.${ALL_OFF}\\\\n\"\)\;\ exit\ 1")
+PKGEXT=".pkg.tar"
+
+prepare() {
+ tail -c+873825 gog_psychonauts_${pkgver}.sh > gog_psychonauts.zip
+ unzip -quo gog_psychonauts.zip
+}
+
+package() {
+ install -Dm644 "$pkgname".desktop "$pkgdir"/usr/share/applications/"$pkgname".desktop
+ install -Dm755 "$pkgname".sh "$pkgdir"/usr/bin/psychonauts
+
+ cd data/noarch
+ install -Dm644 support/icon.png "$pkgdir"/usr/share/pixmaps/psychonauts.png
+
+ # remove libraries shipped with the game
+ rm game/{libSDL-1.2.so.0,libopenal.so.1}
+
+ install -d "$pkgdir"/opt/"$pkgname"/support
+ cp -rp start.sh game "$pkgdir"/opt/"$pkgname"
+ cp -p support/gog_com.shlib "$pkgdir"/opt/"$pkgname"/support
+
+ install -d "$pkgdir"/usr/share/{doc,licenses}/"$pkgname"
+ install -m644 docs/"Psychonauts Manual Win.pdf" "$pkgdir"/usr/share/doc/"$pkgname"
+ install -m644 docs/"End User License Agreement.txt" "$pkgdir"/usr/share/licenses/"$pkgname"
+
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/psychonauts-gog.desktop b/psychonauts-gog.desktop
new file mode 100644
index 000000000000..a4f438fdaaa7
--- /dev/null
+++ b/psychonauts-gog.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Psychonauts
+Comment=Platforming game by Double Fine Productions
+Exec=psychonauts
+Icon=psychonauts
+Terminal=false
+Type=Application
+Categories=Game;
+NoDisplay=false
+StartupNotify=true
diff --git a/psychonauts-gog.sh b/psychonauts-gog.sh
new file mode 100644
index 000000000000..ad44d8d6308c
--- /dev/null
+++ b/psychonauts-gog.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+cd /opt/psychonauts-gog/ && ./start.sh