summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Golatofski2020-01-12 15:26:27 +0100
committerFelix Golatofski2020-01-12 15:26:27 +0100
commit5b4325046cd5b56c08821f57804ab338d9acdee7 (patch)
treee563663edf434429cdb9226f80294a1cfa86ef09
parenta25066087e3296955d5ddc1e86bc846b6e04e6ae (diff)
downloadaur-5b4325046cd5b56c08821f57804ab338d9acdee7.tar.gz
Updated to 3.2.4
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
-rw-r--r--setup.cfg.patch25
3 files changed, 8 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b76aa2cf0c7..558614277bd0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = psychopy
pkgdesc = An experiment builder for neuroscience, psychology and psychophysics
- pkgver = 3.1.2
+ pkgver = 3.2.4
pkgrel = 1
url = http://www.psychopy.org
arch = any
@@ -43,11 +43,10 @@ pkgbase = psychopy
depends = python-wxpython
depends = webkit2gtk
depends = python-mock
+ depends = opencv
optdepends = python-seaborn: For nice graphs
- source = https://github.com/psychopy/psychopy/archive/3.1.2.tar.gz
- source = setup.cfg.patch
- md5sums = 84a8a2c685166625db353e074217d8bf
- md5sums = 51eae5ff98af0e0f83ca7187ff81e055
+ source = https://github.com/psychopy/psychopy/archive/3.2.4.tar.gz
+ sha512sums = 084f8715193d5c6ac836e012a7f082cd027e5ed14a4c08d1ad7db85749df8cec015ded828c32a36f999b5cec51f6d221812f94a21043e5e08d68c5c78b09d6f9
pkgname = psychopy
diff --git a/PKGBUILD b/PKGBUILD
index 57f1989156ec..c5717246993b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Martin Corley <Martin.Corley@ed.ac.uk>
pkgname=psychopy
-pkgver=3.1.2
+pkgver=3.2.4
pkgrel=1
pkgdesc="An experiment builder for neuroscience, psychology and psychophysics"
arch=('any')
@@ -17,22 +17,11 @@ depends=('python-matplotlib' 'python-pandas' 'python-opengl' 'python-pyglet'
'python-gevent' 'python-pyaml' 'python-cryptography' 'python-pyopenssl'
'python-xlrd' 'python-pyosf' 'python-bidi' 'python-esprima'
'python-pyparallel' 'python-psutil' 'python-astunparse' 'python-pyserial'
- 'python-arabic-reshaper' 'python-wxpython' 'webkit2gtk' 'python-mock')
+ 'python-arabic-reshaper' 'python-wxpython' 'webkit2gtk' 'python-mock' 'opencv')
makedepends=('python-wheel' 'python-setuptools')
optdepends=('python-seaborn: For nice graphs')
-source=("https://github.com/${pkgname}/${pkgname}/archive/${pkgver}.tar.gz"
- "setup.cfg.patch")
-md5sums=('84a8a2c685166625db353e074217d8bf'
- '51eae5ff98af0e0f83ca7187ff81e055')
-
-prepare() {
- # apply patch to psychopy requirements in setup.cfg
- # archlinux opencv pacakge provides python bindings, but no metadata
- # wxpython is required for linux
- # psychopy msgpack requirement is outdated with archlinux version
- cd "$srcdir/$pkgname-$pkgver"
- patch --strip=0 --forward --input="$srcdir/setup.cfg.patch"
-}
+source=("https://github.com/${pkgname}/${pkgname}/archive/${pkgver}.tar.gz")
+sha512sums=('084f8715193d5c6ac836e012a7f082cd027e5ed14a4c08d1ad7db85749df8cec015ded828c32a36f999b5cec51f6d221812f94a21043e5e08d68c5c78b09d6f9')
build() {
cd "$srcdir/$pkgname-$pkgver"
diff --git a/setup.cfg.patch b/setup.cfg.patch
deleted file mode 100644
index 118e9a749693..000000000000
--- a/setup.cfg.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- setup.cfg 2019-03-29 03:49:03.000000000 -0700
-+++ setup.cfg.new 2019-04-18 16:32:24.259724316 -0700
-@@ -50,12 +50,11 @@
- pyyaml
- gevent
- msgpack-numpy
-- msgpack-python
-+ msgpack
- psutil
- tables
- pyzmq
- moviepy
-- opencv-python
- python-gitlab
- gitpython
- astunparse
-@@ -69,7 +68,7 @@
- pyWinhook; platform_system == "Windows"
- pyqmix >= 2018.12.13; platform_system == "Windows"
- pyqt5; python_version >= "3"
-- wxPython != 4.0.2, != 4.0.3; platform_system != "Linux"
-+ wxPython
- pypiwin32; platform_system == "Windows"
- pyobjc-core; platform_system == "Darwin"
- pyobjc-framework-Quartz; platform_system == "Darwin"