summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrkcf2019-04-24 17:10:29 -0700
committerrkcf2019-04-24 17:10:29 -0700
commit9d6bf7078b02984be46cfda9f78b04d4d0c3eae1 (patch)
treeef7d65f4f5d881761ef8817579e0c338949f8f3a
parent9f4725b8294470d122bd260277ba05f7ed5db5a0 (diff)
downloadaur-9d6bf7078b02984be46cfda9f78b04d4d0c3eae1.tar.gz
update to 3.0.7
-rw-r--r--.SRCINFO88
-rw-r--r--PKGBUILD114
-rw-r--r--linux2.patch28
-rw-r--r--psychopy.install4
-rw-r--r--run.py.patch9
-rw-r--r--setup.cfg.patch25
6 files changed, 111 insertions, 157 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81a7eebca23d..34d6547e65a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,51 +1,53 @@
pkgbase = psychopy
pkgdesc = An experiment builder for neuroscience, psychology and psychophysics
- pkgver = 1.85.3
+ pkgver = 3.0.7
pkgrel = 1
url = http://www.psychopy.org
arch = any
- license = GPL
- makedepends = python2-setuptools
- depends = ttf-freefont
- depends = desktop-file-utils
- depends = glu
- depends = wxpython
- depends = python2-scipy
- depends = python2-matplotlib
- depends = python2-pandas
- depends = python2-opengl
- depends = python2-pyglet
- depends = python2-imaging
- depends = python2-lxml
- depends = python2-openpyxl
- depends = python2-configobj
- depends = python2-yaml
- depends = python2-gevent
- depends = python2-msgpack
- depends = python2-psutil
- depends = python2-xlrd
- depends = python2-requests
- depends = python2-xlib
- depends = python2-future
- depends = python2-json-tricks
- optdepends = python2-moviepy: For playing movies
- optdepends = python2-pyo: For playing sound (alterative to python2-pysoundcard/python2-pysoundfile)
- optdepends = python2-pysoundcard: For playing sound (alterative to python2-pyo) Requires python2-pysoundfile
- optdepends = python2-pysoundfile: For playing sound (alterative to python2-pyo) Requires python2-pysoundcard
- optdepends = python2-cffi: For playing sound (alterative to python2-pyo)
- optdepends = python2-seaborn: For graphing nicely
- optdepends = python2-bidi: For formatting left-right languages
- optdepends = python2-pyserial: For using the serial port
- optdepends = python2-pyparallel: For using the parallel port
- optdepends = python2-egi: For using egi/pynetstation
- optdepends = python2-iolabs: For using the iolabs button box
- optdepends = python2-xid: For communicating with Cedrus XID and StimTracker devices
- optdepends = python2-labjack: For interacting with the LabJack
- optdepends = python2-pytest: For running unit tests
- optdepends = python2-coverage: For running unit tests
- optdepends = python2-sphinx: For building documentation
- source = https://github.com/psychopy/psychopy/archive/1.85.3.tar.gz
- md5sums = 460afc4344470ed6adaf9f95471e66b0
+ license = GPL3
+ makedepends = python-wheel
+ makedepends = python-setuptools
+ depends = python-matplotlib
+ depends = python-pandas
+ depends = python-opengl
+ depends = python-pyglet
+ depends = python-moviepy
+ depends = python-lxml
+ depends = python-openpyxl
+ depends = python-configobj
+ depends = python-freetype-py
+ depends = python-gitpython
+ depends = python-gitlab
+ depends = python-pyzmq
+ depends = python-json-tricks
+ depends = python-pygame
+ depends = python-pyqt5
+ depends = python-imageio-ffmpeg
+ depends = python-soundfile
+ depends = python-sounddevice
+ depends = python-pytables
+ depends = python-msgpack-numpy
+ depends = python-gevent
+ depends = python-pyaml
+ depends = python-cryptography
+ depends = python-pyopenssl
+ depends = python-xlrd
+ depends = python-pyosf
+ depends = python-bidi
+ depends = python-esprima
+ depends = python-pyparallel
+ depends = python-psutil
+ depends = python-astunparse
+ depends = python-pyserial
+ depends = python-arabic-reshaper
+ depends = python-wxpython
+ depends = webkit2gtk
+ depends = python-mock
+ optdepends = python-seaborn: For nice graphs
+ source = https://github.com/psychopy/psychopy/archive/3.0.7.tar.gz
+ source = setup.cfg.patch
+ md5sums = 6edaaeea126f58b6e73cc2baba07b88c
+ md5sums = 51eae5ff98af0e0f83ca7187ff81e055
pkgname = psychopy
diff --git a/PKGBUILD b/PKGBUILD
index 9e923f319adc..8c3af70bdcc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,85 +1,53 @@
-# Maintainer: Daniel E. Shub <daniel.e.shub@gmail.com>
+# Maintainer: Andrew Steinke <rkcf@rkcf.me>
+# Contributor: Daniel E. Shub <daniel.e.shub@gmail.com>
# Contributor: Martin Corley <Martin.Corley@ed.ac.uk>
pkgname=psychopy
-pkgver=1.85.3
+pkgver=3.0.7
pkgrel=1
pkgdesc="An experiment builder for neuroscience, psychology and psychophysics"
-arch=(any)
+arch=('any')
url="http://www.psychopy.org"
-license=(GPL)
-makedepends=(python2-setuptools)
-
-# Dependencies: Non Python
-depends=(ttf-freefont desktop-file-utils glu)
-
-# Dependencies: PsychoPy application
-## The python2-numpy package is a dependency of python2-pandas and python2-scipy
-depends+=(
- wxpython python2-scipy python2-matplotlib
- python2-pandas python2-opengl python2-pyglet
- python2-imaging python2-lxml
- python2-openpyxl python2-configobj
-)
-
-# Dependencies: ioHub
-## The python2-greenlet package is a dependency of python2-gevent
-## The python2-pytables package is a dependency of python2-pandas
-depends+=(python2-yaml python2-gevent python2-msgpack python2-psutil)
-
-depends+=(python2-xlrd)
-depends+=(python2-requests)
-
-# There is some sort of Arch/ioHub incompatibility that
-# requires patching ioHub to use the python2-xlib
-depends+=(python2-xlib)
-
-# Unlisted dependencies
-depends+=(python2-future python2-json-tricks)
-
-# The python2-pyqt5 package is a dependency of python2-matplotlib
-# The pyosf and psychopy_exts packages are mentioned as optional dependencies, but are not packaged
-optdepends=(
- 'python2-moviepy: For playing movies'
- 'python2-pyo: For playing sound (alterative to python2-pysoundcard/python2-pysoundfile)'
- 'python2-pysoundcard: For playing sound (alterative to python2-pyo) Requires python2-pysoundfile'
- 'python2-pysoundfile: For playing sound (alterative to python2-pyo) Requires python2-pysoundcard'
- 'python2-cffi: For playing sound (alterative to python2-pyo)'
- 'python2-seaborn: For graphing nicely'
- 'python2-bidi: For formatting left-right languages'
- 'python2-pyserial: For using the serial port'
- 'python2-pyparallel: For using the parallel port'
- 'python2-egi: For using egi/pynetstation'
- 'python2-iolabs: For using the iolabs button box'
- 'python2-xid: For communicating with Cedrus XID and StimTracker devices'
- 'python2-labjack: For interacting with the LabJack'
- 'python2-pytest: For running unit tests'
- 'python2-coverage: For running unit tests'
- 'python2-sphinx: For building documentation'
-)
-
-source=(
- "https://github.com/${pkgname}/${pkgname}/archive/${pkgver}.tar.gz"
-)
-md5sums=('460afc4344470ed6adaf9f95471e66b0')
+license=('GPL3')
+depends=('python-matplotlib' 'python-pandas' 'python-opengl' 'python-pyglet'
+ 'python-moviepy' 'python-lxml' 'python-openpyxl' 'python-configobj'
+ 'python-freetype-py' 'python-gitpython' 'python-gitlab' 'python-pyzmq'
+ 'python-json-tricks' 'python-pygame' 'python-pyqt5' 'python-imageio-ffmpeg'
+ 'python-soundfile' 'python-sounddevice' 'python-pytables' 'python-msgpack-numpy'
+ 'python-gevent' 'python-pyaml' 'python-cryptography' 'python-pyopenssl'
+ 'python-xlrd' 'python-pyosf' 'python-bidi' 'python-esprima'
+ 'python-pyparallel' 'python-psutil' 'python-astunparse' 'python-pyserial'
+ 'python-arabic-reshaper' 'python-wxpython' 'webkit2gtk' 'python-mock')
+makedepends=('python-wheel' 'python-setuptools')
+optdepends=('python-seaborn: For nice graphs')
+source=("https://github.com/${pkgname}/${pkgname}/archive/${pkgver}.tar.gz"
+ "setup.cfg.patch")
+md5sums=('6edaaeea126f58b6e73cc2baba07b88c'
+ '51eae5ff98af0e0f83ca7187ff81e055')
prepare() {
- # Make sure all calls are to python2 functions
- sed -i 's/py.test /py.test2 /' \
- "${srcdir}/${pkgname}-${pkgver}/psychopy/tests/run.py"
+ # apply patch to psychopy requirements in setup.cfg
+ # archlinux opencv pacakge provides python bindings, but no metadata
+ # wxpython is required for linux
+ # psychopy msgpack requirement is outdated with archlinux version
+ cd "$srcdir/$pkgname-$pkgver"
+ patch --strip=0 --forward --input="$srcdir/setup.cfg.patch"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
}
package() {
- (
- cd "${srcdir}/${pkgname}-${pkgver}"
- python2 setup.py install --root="${pkgdir}/" --optimize=1
- )
- install -m 755 "${srcdir}/${pkgname}-${pkgver}/psychopy/app/psychopyApp.py" \
- "${pkgdir}/usr/bin/"
- install -Dm644 "${srcdir}/${pkgname}-${pkgver}/psychopy/app/Resources/${pkgname}.desktop" \
- "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -Dm644 "${srcdir}/${pkgname}-${pkgver}/psychopy/app/Resources/${pkgname}.png" \
- "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
- install -Dm644 "${srcdir}/${pkgname}-${pkgver}/psychopy/app/Resources/${pkgname}.xml" \
- "${pkgdir}/usr/share/mime/packages/${pkgname}.xml"
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+
+ # desktop files
+ cd "$pkgname/app/Resources"
+ install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "$pkgname.png" "$pkgdir/usr/share/pixmaps/$psychopy.png"
+ install -Dm644 "$pkgname.xml" "$pkgdir/usr/share/mime/packages/$pkgname.xml"
}
+
+# vim:set ts=2 sw=2 et:
diff --git a/linux2.patch b/linux2.patch
deleted file mode 100644
index 9fb0d3396384..000000000000
--- a/linux2.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-@@ -9,6 +9,7 @@
- from . import MouseDevice
- from ... import print2err,MouseConstants,printExceptionDetailsToStdErr
- from .. import Computer,Keyboard
-+from .. import xlib
-
- currentSec=Computer.getTime
-
-@@ -33,8 +34,6 @@
- if Mouse._xdll is None:
- try:
- Mouse._xdll = cdll.LoadLibrary('libX11.so')
-- Mouse._xdisplay = self._xdll.XOpenDisplay(None)
-- Mouse._xscreen_count = self._xdll.XScreenCount(self._xdisplay)
- try:
- # should use linux cmd:
- # find /usr/lib -name libXfixes.so\*
-@@ -49,6 +48,10 @@
- except:
- print2err('ERROR: Mouse._xdll is None. libX11.so cound not be found')
-
-+
-+ Mouse._xdisplay = xlib.XOpenDisplay(None)
-+ Mouse._xscreen_count = xlib.XScreenCount(Mouse._xdisplay)
-+
- if Mouse._xfixsdll and self._xdll and self._display_device and self._display_device._xwindow is None:
- self._display_device._xwindow= self._xdll.XRootWindow(Mouse._xdisplay, self._display_device.getIndex())
-
diff --git a/psychopy.install b/psychopy.install
deleted file mode 100644
index bca322ab7d35..000000000000
--- a/psychopy.install
+++ /dev/null
@@ -1,4 +0,0 @@
-post_install() {
- update-desktop-database -q
- update-mime-database usr/share/mime
-}
diff --git a/run.py.patch b/run.py.patch
deleted file mode 100644
index d4a99b3d898e..000000000000
--- a/run.py.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-@@ -44,7 +44,7 @@
- # query_reply=touch.queryDevice('ID')
- #
- id_dict=touch.queryDevice('ID')
-- print("queryDevice('ID'):" + str(,id_dict))
-+ print("queryDevice('ID'):" + str(id_dict))
- print()
-
- # getHardwareConfiguration returns the results from the following
diff --git a/setup.cfg.patch b/setup.cfg.patch
new file mode 100644
index 000000000000..118e9a749693
--- /dev/null
+++ b/setup.cfg.patch
@@ -0,0 +1,25 @@
+--- setup.cfg 2019-03-29 03:49:03.000000000 -0700
++++ setup.cfg.new 2019-04-18 16:32:24.259724316 -0700
+@@ -50,12 +50,11 @@
+ pyyaml
+ gevent
+ msgpack-numpy
+- msgpack-python
++ msgpack
+ psutil
+ tables
+ pyzmq
+ moviepy
+- opencv-python
+ python-gitlab
+ gitpython
+ astunparse
+@@ -69,7 +68,7 @@
+ pyWinhook; platform_system == "Windows"
+ pyqmix >= 2018.12.13; platform_system == "Windows"
+ pyqt5; python_version >= "3"
+- wxPython != 4.0.2, != 4.0.3; platform_system != "Linux"
++ wxPython
+ pypiwin32; platform_system == "Windows"
+ pyobjc-core; platform_system == "Darwin"
+ pyobjc-framework-Quartz; platform_system == "Darwin"