summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel E. Shub2017-08-31 18:21:15 -0400
committerDaniel E. Shub2017-08-31 18:21:15 -0400
commit9f4725b8294470d122bd260277ba05f7ed5db5a0 (patch)
treeb7952e06a2b1b8a50dcd341205230ce9466226a7
parente30f4ba9d2365fc01afee0c2163c40daac04f556 (diff)
downloadaur-9f4725b8294470d122bd260277ba05f7ed5db5a0.tar.gz
1.85.3-1
-rw-r--r--.SRCINFO53
-rw-r--r--PKGBUILD97
2 files changed, 96 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bfef25c22fed..81a7eebca23d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,48 +1,51 @@
pkgbase = psychopy
pkgdesc = An experiment builder for neuroscience, psychology and psychophysics
- pkgver = 1.84.1
+ pkgver = 1.85.3
pkgrel = 1
url = http://www.psychopy.org
arch = any
license = GPL
makedepends = python2-setuptools
+ depends = ttf-freefont
depends = desktop-file-utils
- depends = python2-configobj
- depends = python2-requests
- depends = python2-moviepy
- depends = python2
+ depends = glu
depends = wxpython
- depends = python2-numpy
- depends = python2-pandas
depends = python2-scipy
- depends = python2-imaging
- depends = python2-lxml
- depends = python2-pyglet
depends = python2-matplotlib
- depends = glu
- depends = python2-pyo
+ depends = python2-pandas
depends = python2-opengl
- depends = python2-pygame
- depends = avbin7
+ depends = python2-pyglet
+ depends = python2-imaging
+ depends = python2-lxml
depends = python2-openpyxl
- depends = ttf-freefont
- depends = python2-psutil
+ depends = python2-configobj
depends = python2-yaml
depends = python2-gevent
depends = python2-msgpack
+ depends = python2-psutil
+ depends = python2-xlrd
+ depends = python2-requests
depends = python2-xlib
- depends = python2-pytables
- optdepends = python2-pyparallel: To use the parallel port
- optdepends = python2-pyserial: For interfacing with the serial port
- optdepends = parallel-python: For parallel processing
- optdepends = flac: For working with google speech
+ depends = python2-future
+ depends = python2-json-tricks
+ optdepends = python2-moviepy: For playing movies
+ optdepends = python2-pyo: For playing sound (alterative to python2-pysoundcard/python2-pysoundfile)
+ optdepends = python2-pysoundcard: For playing sound (alterative to python2-pyo) Requires python2-pysoundfile
+ optdepends = python2-pysoundfile: For playing sound (alterative to python2-pyo) Requires python2-pysoundcard
+ optdepends = python2-cffi: For playing sound (alterative to python2-pyo)
+ optdepends = python2-seaborn: For graphing nicely
+ optdepends = python2-bidi: For formatting left-right languages
+ optdepends = python2-pyserial: For using the serial port
+ optdepends = python2-pyparallel: For using the parallel port
+ optdepends = python2-egi: For using egi/pynetstation
+ optdepends = python2-iolabs: For using the iolabs button box
+ optdepends = python2-xid: For communicating with Cedrus XID and StimTracker devices
+ optdepends = python2-labjack: For interacting with the LabJack
optdepends = python2-pytest: For running unit tests
optdepends = python2-coverage: For running unit tests
optdepends = python2-sphinx: For building documentation
- source = https://github.com/psychopy/psychopy/archive/1.84.1.tar.gz
- source = linux2.patch
- md5sums = 4d250422f370ecc1d84a5649589c17ed
- md5sums = 3b55a69e8b37a621d8d1346aa2239fc6
+ source = https://github.com/psychopy/psychopy/archive/1.85.3.tar.gz
+ md5sums = 460afc4344470ed6adaf9f95471e66b0
pkgname = psychopy
diff --git a/PKGBUILD b/PKGBUILD
index 66d5ffe1bab8..9e923f319adc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,45 +2,84 @@
# Contributor: Martin Corley <Martin.Corley@ed.ac.uk>
pkgname=psychopy
-pkgver=1.84.1
+pkgver=1.85.3
pkgrel=1
pkgdesc="An experiment builder for neuroscience, psychology and psychophysics"
arch=(any)
url="http://www.psychopy.org"
license=(GPL)
makedepends=(python2-setuptools)
-depends=(desktop-file-utils python2-configobj python2-requests python2-moviepy python2 wxpython python2-numpy python2-pandas python2-scipy python2-imaging python2-lxml python2-pyglet python2-matplotlib glu python2-pyo python2-opengl python2-pygame avbin7 python2-openpyxl ttf-freefont python2-psutil python2-yaml python2-gevent python2-msgpack python2-xlib python2-pytables)
-optdepends=('python2-pyparallel: To use the parallel port'
- 'python2-pyserial: For interfacing with the serial port'
- 'parallel-python: For parallel processing'
- 'flac: For working with google speech'
- 'python2-pytest: For running unit tests'
- 'python2-coverage: For running unit tests'
- 'python2-sphinx: For building documentation')
-source=("https://github.com/${pkgname}/${pkgname}/archive/${pkgver}.tar.gz"
- 'linux2.patch'
+
+# Dependencies: Non Python
+depends=(ttf-freefont desktop-file-utils glu)
+
+# Dependencies: PsychoPy application
+## The python2-numpy package is a dependency of python2-pandas and python2-scipy
+depends+=(
+ wxpython python2-scipy python2-matplotlib
+ python2-pandas python2-opengl python2-pyglet
+ python2-imaging python2-lxml
+ python2-openpyxl python2-configobj
)
-md5sums=('4d250422f370ecc1d84a5649589c17ed'
- '3b55a69e8b37a621d8d1346aa2239fc6')
-prepare() {
- # Deal with iohub issues
- patch "${srcdir}/${pkgname}-${pkgver}/psychopy/iohub/devices/mouse/linux2.py" < \
- "${srcdir}/linux2.patch"
+# Dependencies: ioHub
+## The python2-greenlet package is a dependency of python2-gevent
+## The python2-pytables package is a dependency of python2-pandas
+depends+=(python2-yaml python2-gevent python2-msgpack python2-psutil)
+
+depends+=(python2-xlrd)
+depends+=(python2-requests)
+
+# There is some sort of Arch/ioHub incompatibility that
+# requires patching ioHub to use the python2-xlib
+depends+=(python2-xlib)
+
+# Unlisted dependencies
+depends+=(python2-future python2-json-tricks)
- # Make sure all calls are to python2 functions
- sed -i 's/py.test /py.test2 /' "${srcdir}/${pkgname}-${pkgver}/psychopy/tests/run.py"
+# The python2-pyqt5 package is a dependency of python2-matplotlib
+# The pyosf and psychopy_exts packages are mentioned as optional dependencies, but are not packaged
+optdepends=(
+ 'python2-moviepy: For playing movies'
+ 'python2-pyo: For playing sound (alterative to python2-pysoundcard/python2-pysoundfile)'
+ 'python2-pysoundcard: For playing sound (alterative to python2-pyo) Requires python2-pysoundfile'
+ 'python2-pysoundfile: For playing sound (alterative to python2-pyo) Requires python2-pysoundcard'
+ 'python2-cffi: For playing sound (alterative to python2-pyo)'
+ 'python2-seaborn: For graphing nicely'
+ 'python2-bidi: For formatting left-right languages'
+ 'python2-pyserial: For using the serial port'
+ 'python2-pyparallel: For using the parallel port'
+ 'python2-egi: For using egi/pynetstation'
+ 'python2-iolabs: For using the iolabs button box'
+ 'python2-xid: For communicating with Cedrus XID and StimTracker devices'
+ 'python2-labjack: For interacting with the LabJack'
+ 'python2-pytest: For running unit tests'
+ 'python2-coverage: For running unit tests'
+ 'python2-sphinx: For building documentation'
+)
+
+source=(
+ "https://github.com/${pkgname}/${pkgname}/archive/${pkgver}.tar.gz"
+)
+md5sums=('460afc4344470ed6adaf9f95471e66b0')
+
+prepare() {
+ # Make sure all calls are to python2 functions
+ sed -i 's/py.test /py.test2 /' \
+ "${srcdir}/${pkgname}-${pkgver}/psychopy/tests/run.py"
}
package() {
- (cd "${srcdir}/${pkgname}-${pkgver}"; \
- python2 setup.py install --root="${pkgdir}/" --optimize=1)
- install -m 755 "${srcdir}/${pkgname}-${pkgver}/psychopy/app/psychopyApp.py" \
- "${pkgdir}/usr/bin/"
- install -Dm644 "${srcdir}/${pkgname}-${pkgver}/psychopy/app/Resources/${pkgname}.desktop" \
- "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -Dm644 "${srcdir}/${pkgname}-${pkgver}/psychopy/app/Resources/${pkgname}.png" \
- "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
- install -Dm644 "${srcdir}/${pkgname}-${pkgver}/psychopy/app/Resources/${pkgname}.xml" \
- "${pkgdir}/usr/share/mime/packages/${pkgname}.xml"
+ (
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+ )
+ install -m 755 "${srcdir}/${pkgname}-${pkgver}/psychopy/app/psychopyApp.py" \
+ "${pkgdir}/usr/bin/"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/psychopy/app/Resources/${pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/psychopy/app/Resources/${pkgname}.png" \
+ "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/psychopy/app/Resources/${pkgname}.xml" \
+ "${pkgdir}/usr/share/mime/packages/${pkgname}.xml"
}