summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel E. Shub2021-10-26 16:28:04 -0400
committerDaniel E. Shub2021-10-26 16:28:04 -0400
commitbfb6fa7d3efc4ea619f2f93733e9237d05eeaaf7 (patch)
tree8ac5eedfa9011386449f25c4a238ffb5601ad2d0
parentd3fc10010b042095c707726193e7904904325af9 (diff)
downloadaur-bfb6fa7d3efc4ea619f2f93733e9237d05eeaaf7.tar.gz
2021.2.3-1
-rw-r--r--.SRCINFO50
-rw-r--r--PKGBUILD15
2 files changed, 39 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 718f39b5935b..14f7019904ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,37 @@
pkgbase = psychopy
pkgdesc = An experiment builder for neuroscience, psychology and psychophysics
- pkgver = 2021.1.0
+ pkgver = 2021.2.3
pkgrel = 1
url = http://www.psychopy.org
arch = any
license = GPL3
makedepends = python-setuptools
+ depends = python-pyosf
+ optdepends = python-seaborn: For nice graphs
+ source = https://github.com/psychopy/psychopy/archive/2021.2.3.tar.gz
+ sha512sums = ac0504779a3cfa8e51f6b641fb6c1453b790fed0c924a0bab9d9fba91ddfd1cd0ffadf52cf5e7f1b73bbf394aee43fb213cf472664d9e671adacf2cb27923fd7
+
+pkgname = psychopy
+ depends = python-pyosf
+ depends = python
+ depends = python-packaging
depends = python-requests
+ depends = python-cryptography
depends = python-numpy
depends = python-scipy
depends = python-matplotlib
depends = python-pandas
depends = python-pillow
depends = python-glfw
+ depends = python-pygame
depends = python-opengl
- depends = python-sounddevice
+ depends = python-pyo
depends = python-soundfile
+ depends = python-sounddevice
depends = python-bidi
depends = python-arabic-reshaper
depends = python-future
depends = python-json-tricks
- depends = python-pyosf
depends = python-xlrd
depends = python-openpyxl
depends = python-pyserial
@@ -31,35 +42,26 @@ pkgbase = psychopy
depends = python-psutil
depends = python-pytables
depends = python-pyzmq
+ depends = python-ujson
depends = python-moviepy
- depends = opencv
depends = python-gitlab
depends = python-gitpython
depends = python-astunparse
depends = python-esprima
depends = python-freetype-py
- depends = python-javascripthon
+ depends = python-jedi
+ depends = python-psychtoolbox
+ depends = python-websocket-client
depends = python-pyglet
- depends = python-questplus
+ depends = python-wxpython
+ depends = python-vlc
+ depends = python-pyparallel
+ depends = python-xlib
+ depends = python-distro
depends = python-imageio
depends = python-imageio-ffmpeg
- depends = python-pyparallel
depends = python-pyqt5
- depends = python-wxpython
- depends = python-distro
- depends = python-psychtoolbox
- depends = python-cryptography
- depends = python-pyopenssl
+ depends = python-javascripthon
+ depends = python-questplus
depends = webkit2gtk
- depends = python-xlib
- depends = python-pyglet
- depends = python-websocket-client
- depends = python-jedi
- depends = python-vlc
- depends = python-ujson
- optdepends = python-seaborn: For nice graphs
- source = https://github.com/psychopy/psychopy/archive/2021.1.0.tar.gz
- sha512sums = ac0504779a3cfa8e51f6b641fb6c1453b790fed0c924a0bab9d9fba91ddfd1cd0ffadf52cf5e7f1b73bbf394aee43fb213cf472664d9e671adacf2cb27923fd7
-
-pkgname = psychopy
-
+ depends = python-xmlschema
diff --git a/PKGBUILD b/PKGBUILD
index 1170ae12a3eb..bc802334580e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
# Contributor: Martin Corley <Martin.Corley@ed.ac.uk>
pkgname=psychopy
-pkgver=2021.1.0
+pkgver=2021.2.3
pkgrel=1
pkgdesc="An experiment builder for neuroscience, psychology and psychophysics"
arch=('any')
url="http://www.psychopy.org"
license=('GPL3')
makedepends=(python-setuptools)
-depends=(python-requests python-numpy python-scipy python-matplotlib python-pandas python-pillow python-glfw python-opengl python-sounddevice python-soundfile python-bidi python-arabic-reshaper python-future python-json-tricks python-pyosf python-xlrd python-openpyxl python-pyserial python-pyaml python-gevent python-msgpack python-msgpack-numpy python-psutil python-pytables python-pyzmq python-moviepy opencv python-gitlab python-gitpython python-astunparse python-esprima python-freetype-py python-javascripthon python-pyglet python-questplus python-imageio python-imageio-ffmpeg python-pyparallel python-pyqt5 python-wxpython python-distro python-psychtoolbox python-cryptography python-pyopenssl webkit2gtk python-xlib python-pyglet python-websocket-client python-jedi python-vlc python-ujson)
+depends=(python-pyosf)
optdepends=('python-seaborn: For nice graphs')
source=("https://github.com/psychopy/psychopy/archive/${pkgver}.tar.gz")
@@ -20,12 +20,23 @@ sha512sums=('ac0504779a3cfa8e51f6b641fb6c1453b790fed0c924a0bab9d9fba91ddfd1cd0ff
build() {
cd "$srcdir/$pkgname-$pkgver"
rm -rf packaging/
+
+ # The opencv package in Arch is compiled with the python bindings so the python package is not needed
sed -i '/opencv-python/d' setup.cfg
+
+ # The python-pyglet package is required, but the Arch version is newer than the one specified in setup.cfg. There is probably a cleaner way to do this ...
sed -i '/pyglet/d' setup.cfg
+
python setup.py build
}
package() {
+ # These packages come from setup.cfg
+ depends+=(python python-packaging python-requests python-cryptography python-numpy python-scipy python-matplotlib python-pandas python-pillow python-glfw python-pygame python-opengl python-pyo python-soundfile python-sounddevice python-bidi python-arabic-reshaper python-future python-json-tricks python-xlrd python-openpyxl python-pyserial python-pyaml python-gevent python-msgpack python-msgpack-numpy python-psutil python-pytables python-pyzmq python-ujson python-moviepy python-gitlab python-gitpython python-astunparse python-esprima python-freetype-py python-jedi python-psychtoolbox python-websocket-client python-pyglet python-wxpython python-vlc python-pyparallel python-xlib python-distro python-imageio python-imageio-ffmpeg python-pyqt5 python-javascripthon python-questplus)
+
+ # These packages seem to be required
+ depends+=(webkit2gtk python-xmlschema)
+
cd "$srcdir/$pkgname-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build