summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel E. Shub2021-02-23 23:37:48 -0500
committerDaniel E. Shub2021-02-23 23:37:48 -0500
commitd3fc10010b042095c707726193e7904904325af9 (patch)
treea52530e9b772d8edf1bfe8e94e62cc71e311867f
parent245ca4d7e764c21b23b3088172f8cef1dd532a38 (diff)
downloadaur-d3fc10010b042095c707726193e7904904325af9.tar.gz
2021.1.0-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD14
2 files changed, 18 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c114f10d9d70..718f39b5935b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = psychopy
pkgdesc = An experiment builder for neuroscience, psychology and psychophysics
- pkgver = 2020.1.3
- pkgrel = 4
+ pkgver = 2021.1.0
+ pkgrel = 1
url = http://www.psychopy.org
arch = any
license = GPL3
- makedepends = python-wheel
makedepends = python-setuptools
depends = python-requests
depends = python-numpy
@@ -52,9 +51,15 @@ pkgbase = psychopy
depends = python-cryptography
depends = python-pyopenssl
depends = webkit2gtk
+ depends = python-xlib
+ depends = python-pyglet
+ depends = python-websocket-client
+ depends = python-jedi
+ depends = python-vlc
+ depends = python-ujson
optdepends = python-seaborn: For nice graphs
- source = https://github.com/psychopy/psychopy/archive/2020.1.3.tar.gz
- sha512sums = ef0d510b8f1ca739ae74f1da8d04b234665703cb29f0faebd04d171c9330aac7b2879a53142981bb4fc3bdecc95e7ccbdf80d94a687ee511e195942d1e3b94cf
+ source = https://github.com/psychopy/psychopy/archive/2021.1.0.tar.gz
+ sha512sums = ac0504779a3cfa8e51f6b641fb6c1453b790fed0c924a0bab9d9fba91ddfd1cd0ffadf52cf5e7f1b73bbf394aee43fb213cf472664d9e671adacf2cb27923fd7
pkgname = psychopy
diff --git a/PKGBUILD b/PKGBUILD
index a42b6f9135fb..1170ae12a3eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,29 +4,31 @@
# Contributor: Martin Corley <Martin.Corley@ed.ac.uk>
pkgname=psychopy
-pkgver=2020.1.3
-pkgrel=4
+pkgver=2021.1.0
+pkgrel=1
pkgdesc="An experiment builder for neuroscience, psychology and psychophysics"
arch=('any')
url="http://www.psychopy.org"
license=('GPL3')
-makedepends=(python-wheel python-setuptools)
-depends=(python-requests python-numpy python-scipy python-matplotlib python-pandas python-pillow python-glfw python-opengl python-sounddevice python-soundfile python-bidi python-arabic-reshaper python-future python-json-tricks python-pyosf python-xlrd python-openpyxl python-pyserial python-pyaml python-gevent python-msgpack python-msgpack-numpy python-psutil python-pytables python-pyzmq python-moviepy opencv python-gitlab python-gitpython python-astunparse python-esprima python-freetype-py python-javascripthon python-pyglet python-questplus python-imageio python-imageio-ffmpeg python-pyparallel python-pyqt5 python-wxpython python-distro python-psychtoolbox python-cryptography python-pyopenssl webkit2gtk)
+makedepends=(python-setuptools)
+depends=(python-requests python-numpy python-scipy python-matplotlib python-pandas python-pillow python-glfw python-opengl python-sounddevice python-soundfile python-bidi python-arabic-reshaper python-future python-json-tricks python-pyosf python-xlrd python-openpyxl python-pyserial python-pyaml python-gevent python-msgpack python-msgpack-numpy python-psutil python-pytables python-pyzmq python-moviepy opencv python-gitlab python-gitpython python-astunparse python-esprima python-freetype-py python-javascripthon python-pyglet python-questplus python-imageio python-imageio-ffmpeg python-pyparallel python-pyqt5 python-wxpython python-distro python-psychtoolbox python-cryptography python-pyopenssl webkit2gtk python-xlib python-pyglet python-websocket-client python-jedi python-vlc python-ujson)
optdepends=('python-seaborn: For nice graphs')
source=("https://github.com/psychopy/psychopy/archive/${pkgver}.tar.gz")
-sha512sums=('ef0d510b8f1ca739ae74f1da8d04b234665703cb29f0faebd04d171c9330aac7b2879a53142981bb4fc3bdecc95e7ccbdf80d94a687ee511e195942d1e3b94cf')
+sha512sums=('ac0504779a3cfa8e51f6b641fb6c1453b790fed0c924a0bab9d9fba91ddfd1cd0ffadf52cf5e7f1b73bbf394aee43fb213cf472664d9e671adacf2cb27923fd7')
build() {
cd "$srcdir/$pkgname-$pkgver"
rm -rf packaging/
+ sed -i '/opencv-python/d' setup.cfg
+ sed -i '/pyglet/d' setup.cfg
python setup.py build
}
package() {
cd "$srcdir/$pkgname-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
-
+
# desktop files
cd "$pkgname/app/Resources"
install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"