summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaulo Alexandre2018-04-11 00:12:36 -0300
committerPaulo Alexandre2018-04-11 00:12:36 -0300
commit9ef47acdbcf719a46cb37f094978a5fb72fa1bd8 (patch)
tree7083a8945142ef6808bd054c5e7519f0d288f4ed
downloadaur-9ef47acdbcf719a46cb37f094978a5fb72fa1bd8.tar.gz
v0.1.3
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
-rw-r--r--psync.install3
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f7f421da074
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = psync
+ pkgdesc = A naive tool for syncing partitions using rsync
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://github.com/paulequilibrio/psync
+ install = psync.install
+ arch = any
+ license = AGPL3
+ makedepends = git
+ depends = python-docopt
+ depends = python-yaml
+ depends = rsync
+ depends = beep
+ source = git+https://github.com/paulequilibrio/psync
+ sha256sums = SKIP
+
+pkgname = psync
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dbdc3bb84d55
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Creator: Paulo Alexandre Aquino da Costa <contact at pauloalexandre dot com>
+
+# Maintainer: Paulo Alexandre Aquino da Costa <contact at pauloalexandre dot com>
+pkgname='psync'
+pkgver='0.1.3'
+pkgrel=1
+pkgdesc='A naive tool for syncing partitions using rsync'
+arch=('any')
+url="https://github.com/paulequilibrio/${pkgname}"
+license=('AGPL3')
+depends=('python-docopt' 'python-yaml' 'rsync' 'beep')
+makedepends=('git')
+install="${pkgname}.install"
+source=("git+https://github.com/paulequilibrio/${pkgname}")
+sha256sums=('SKIP')
+
+package() {
+ install -dm 755 "$pkgdir"/{etc,usr/{bin,share/man/man8,lib/$pkgname/source}}
+ cd "$pkgname"
+ install -Dm 644 'LICENSE' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm 644 'examples/simple_config.yaml' "$pkgdir/etc/$pkgname/simple_config.yaml"
+ install -Dm 755 "documentation/${pkgname}.8" "$pkgdir/usr/share/man/man8/${pkgname}.8"
+ install -Dm 755 "$pkgname" "$pkgdir/usr/lib/$pkgname/$pkgname"
+ cd source
+ install -Dm 644 "__init__.py" "$pkgdir/usr/lib/${pkgname}/source/__init__.py"
+ install -Dm 644 "helpers.py" "$pkgdir/usr/lib/${pkgname}/source/helpers.py"
+ install -Dm 644 "bash.py" "$pkgdir/usr/lib/${pkgname}/source/bash.py"
+ install -Dm 755 "${pkgname}.py" "$pkgdir/usr/lib/${pkgname}/source/${pkgname}.py"
+ ln -s "/usr/lib/$pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}
diff --git a/psync.install b/psync.install
new file mode 100644
index 000000000000..852ddf4250af
--- /dev/null
+++ b/psync.install
@@ -0,0 +1,3 @@
+post_remove() {
+ rm -rf /usr/lib/psync/
+}