summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcondy09192016-02-01 19:28:40 +0800
committercondy09192016-02-01 19:28:40 +0800
commit34110703cfff7422bc1930e432186c934b7f16e4 (patch)
tree0f0d52a918ceab2c404fca427329b235be25c9a4
downloadaur-34110703cfff7422bc1930e432186c934b7f16e4.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD21
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9cf16f0e6fb0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Mon Feb 1 11:27:31 UTC 2016
+pkgbase = psysh
+ pkgdesc = PsySH is a runtime developer console, interactive debugger and REPL for PHP.
+ pkgver = 0.6.1
+ pkgrel = 1
+ url = http://psysh.org
+ arch = x86_64
+ arch = i686
+ license = MIT
+ depends = php
+ optdepends = mariadb: mysql command support
+ provides = psysh
+ source = http://psysh.org/psysh
+ source = https://raw.githubusercontent.com/bobthecow/psysh/master/LICENSE
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = psysh
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e70dd8b0363e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: condy <condy0919[at]gmail[dot]com>
+pkgname=psysh
+pkgver=0.6.1
+pkgrel=1
+pkgdesc="PsySH is a runtime developer console, interactive debugger and REPL for PHP."
+url="http://psysh.org"
+arch=('x86_64' 'i686')
+license=('MIT')
+depends=('php')
+provides=('psysh')
+optdepends=('mariadb: mysql command support')
+source=('http://psysh.org/psysh'
+ 'https://raw.githubusercontent.com/bobthecow/psysh/master/LICENSE')
+md5sums=('SKIP'
+ 'SKIP')
+
+package() {
+ cd "${srcdir}"
+ install -Dm755 psysh "$pkgdir/usr/bin/psysh"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}