summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Schürmann2017-05-26 08:51:44 +0200
committerJonas Schürmann2017-05-26 08:51:44 +0200
commit78c44221ba64dacb2a6922f779ff5a1680d5e5a3 (patch)
tree4c055b106c4db20b243a406cf9c71375c841f69c
parent16523748a5c699dac9be815818281d702c6534ff (diff)
downloadaur-78c44221ba64dacb2a6922f779ff5a1680d5e5a3.tar.gz
Use proper release tarballs, upgrade to 0.8.5
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 5 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index d293bc32e6e6..f08eb23ec394 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: condy <condy0919[at]gmail[dot]com>
pkgname=psysh
-pkgver=0.7.2
+pkgver=0.8.5
pkgrel=1
pkgdesc="PsySH is a runtime developer console, interactive debugger and REPL for PHP."
url="http://psysh.org"
@@ -9,13 +9,13 @@ license=('MIT')
depends=('php')
provides=('psysh')
optdepends=('mariadb: mysql command support')
-source=('http://psysh.org/psysh'
+source=("https://github.com/bobthecow/psysh/releases/download/v${pkgver}/psysh-v${pkgver}.tar.gz"
'https://raw.githubusercontent.com/bobthecow/psysh/master/LICENSE')
-md5sums=('SKIP'
- 'SKIP')
+sha256sums=('f7c6e3d710a669159556ea34565db9ce6c88e28fe81d45258b6e04dfa4ff52c5'
+ 'ffe06af119d0b31e8d5bcfd219648d071023380fb3006b6b07017902ef632ad1')
package() {
cd "${srcdir}"
- install -Dm755 psysh "$pkgdir/usr/bin/psysh"
+ install -Dm755 psysh "${pkgdir}/usr/bin/psysh"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}