summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo2021-03-31 17:04:11 +0800
committerLeo2021-03-31 17:04:58 +0800
commit9adcbfbbed2ab1f4f0307430b8f5a7874d876e62 (patch)
tree3917f3b9c67ca55c71fee71fb0b80553cbdd5890
parentd7ce0416cd1b143f4ecb2a8da681767a89bc3b48 (diff)
downloadaur-9adcbfbbed2ab1f4f0307430b8f5a7874d876e62.tar.gz
New upstream version 0.10.7
Create post-install script for dependency notice.
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--.install26
-rw-r--r--PKGBUILD33
4 files changed, 53 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b7d2a6877ec..430e2fa2eed6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = psysh
- pkgdesc = PsySH is a runtime developer console, interactive debugger and REPL for PHP.
- pkgver = 0.10.4
+ pkgdesc = A runtime developer console, interactive debugger and REPL for PHP.
+ pkgver = 0.10.7
pkgrel = 1
- url = http://psysh.org
+ url = https://psysh.org/
+ install = .install
arch = x86_64
- arch = i686
license = MIT
depends = php
- optdepends = mariadb: mysql command support
- provides = psysh
- source = https://github.com/bobthecow/psysh/releases/download/v0.10.4/psysh-v0.10.4.tar.gz
- source = LICENSE-0.10.4::https://raw.githubusercontent.com/bobthecow/psysh/v0.10.4/LICENSE
- sha256sums = c12103b0e36b67776dbcd02966a026fb5c90ef4f26ffbf7df27a89f07381bd00
+ source = https://github.com/bobthecow/psysh/releases/download/v0.10.7/psysh-v0.10.7.tar.gz
+ source = LICENSE-0.10.7::https://raw.githubusercontent.com/bobthecow/psysh/v0.10.7/LICENSE
+ sha256sums = fc16ed778ad1d4b22ce35165981a9f985b169e11f8681129d432181b23b05f74
sha256sums = ea877138671d7068328bf698de950f09a13429ff49096202414472ffbdeeab66
pkgname = psysh
diff --git a/.gitignore b/.gitignore
index 018a3de08144..8d6f9c164c9f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*
!PKGBUILD
+!*.install
!.SRCINFO
!.gitignore
diff --git a/.install b/.install
new file mode 100644
index 000000000000..98cac9472058
--- /dev/null
+++ b/.install
@@ -0,0 +1,26 @@
+# Copied from AUR/google-chrome
+
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+post_install() {
+ note "To fulfill the dependency requirements, "
+ note "please make sure PHP extension iconv is available "
+ note "by confirming the following line exists in /etc/php/php.ini "
+ note " extension=iconv"
+}
+
+post_upgrade() {
+ post_install
+} \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 49bed8d0ab11..a2071eebe381 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,27 @@
-# Maintainer: Jonas Schürmann <jonasschuermann@aol.de>
+# Maintainer: Leo <i@setuid0.dev>
+# Contributor: Jonas Schürmann <jonasschuermann@aol.de>
# Contributor: condy <condy0919[at]gmail[dot]com>
+
pkgname=psysh
-pkgver=0.10.4
+pkgver=0.10.7
pkgrel=1
-pkgdesc="PsySH is a runtime developer console, interactive debugger and REPL for PHP."
-url="http://psysh.org"
-arch=('x86_64' 'i686')
+pkgdesc="A runtime developer console, interactive debugger and REPL for PHP."
+url="https://psysh.org/"
+arch=('x86_64')
license=('MIT')
depends=('php')
-provides=('psysh')
-optdepends=('mariadb: mysql command support')
-source=("https://github.com/bobthecow/psysh/releases/download/v${pkgver}/psysh-v${pkgver}.tar.gz"
- "LICENSE-${pkgver}::https://raw.githubusercontent.com/bobthecow/psysh/v${pkgver}/LICENSE")
-sha256sums=('c12103b0e36b67776dbcd02966a026fb5c90ef4f26ffbf7df27a89f07381bd00'
- 'ea877138671d7068328bf698de950f09a13429ff49096202414472ffbdeeab66')
+install=.install
+source=(
+ "https://github.com/bobthecow/psysh/releases/download/v${pkgver}/psysh-v${pkgver}.tar.gz"
+ "LICENSE-${pkgver}::https://raw.githubusercontent.com/bobthecow/psysh/v${pkgver}/LICENSE"
+)
+sha256sums=(
+ 'fc16ed778ad1d4b22ce35165981a9f985b169e11f8681129d432181b23b05f74'
+ 'ea877138671d7068328bf698de950f09a13429ff49096202414472ffbdeeab66'
+)
package() {
- cd "${srcdir}"
- install -Dm755 psysh "${pkgdir}/usr/bin/psysh"
- install -Dm644 "LICENSE-${pkgver}" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${srcdir}"
+ install -Dm755 psysh "${pkgdir}/usr/bin/psysh"
+ install -Dm644 "LICENSE-${pkgver}" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}