summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoost Bremmer2016-05-24 08:50:14 +0200
committerJoost Bremmer2016-05-24 08:54:25 +0200
commit2ebf3e82a5aa496129d44e828cc1e7a12e290b89 (patch)
treefa8b1cab1b3113c4e6aacfac581c0797ab292ee9
parent3a1379a9c46c2b96085a75067fd357275e7844b9 (diff)
downloadaur-2ebf3e82a5aa496129d44e828cc1e7a12e290b89.tar.gz
update pkg: ptask-git 1.0.0.r1.g9554c87-1
new upstream release! Seems upstream development is back on + added new patch for 2.5.1 (officially supports up to 2.5.0) + removed ptask.install, decaprecated by hooks + see man alpm-hooks (5) for more info + added maximum version number requirement to task + add maximum version number for task + because of this you won't be able to update task beyond what ptask supports, but I will keep up the patches if there aren't any immediate support issues.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
-rw-r--r--task-2.5.1-compat.patch14
3 files changed, 25 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9c901f51440..8574beedd919 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,24 @@
pkgbase = ptask-git
pkgdesc = A GTK+ graphical user interface for managing tasks in taskwarrior
- pkgver = 0.0.9.r9.g2b8b4aa
- pkgrel = 3
+ pkgver = 1.0.0.r1.g9554c87
+ pkgrel = 1
url = http://wpitchoune.net/ptask
- install = ptask-git.install
arch = i686
arch = x86_64
license = GPL2
makedepends = git
makedepends = help2man
makedepends = asciidoc
- depends = task
+ depends = task<=2.5.1
depends = json-c
depends = gtk3
depends = xdg-utils
provides = ptask
conflicts = ptask
source = ptask-git::git+http://git.wpitchoune.net/ptask.git
- source = task-2.5-compat.patch
+ source = task-2.5.1-compat.patch
sha512sums = SKIP
- sha512sums = ffe243097a6580105820fa2ba84b52667ba8d97c34b9e377b54ce297896dbb695fab47d66c634dff724d4c676bf60a83690e5d574b7b34c0b757558f305a6a23
+ sha512sums = 52f57df194d69b8b1541a9b28af18976bc346ce26c607d28ffcd23fc99df6e463336cb2f176e61199b6b301c477613e0f9a98c1fba9f80aa140ab1b73a2c8aa7
pkgname = ptask-git
diff --git a/PKGBUILD b/PKGBUILD
index 694bdb86fce0..dabe1b4bbe1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,24 @@
# Contributor: Robert Orzanna <orschiro@gmail.com>
pkgname=ptask-git
-pkgver=0.0.9.r9.g2b8b4aa
-pkgrel=3
+pkgver=1.0.0.r1.g9554c87
+pkgrel=1
pkgdesc='A GTK+ graphical user interface for managing tasks in taskwarrior'
arch=('i686'
'x86_64')
url='http://wpitchoune.net/ptask'
license=('GPL2')
-depends=('task'
+depends=('task<=2.5.1'
'json-c'
'gtk3'
'xdg-utils')
makedepends=('git'
'help2man'
'asciidoc')
-install=$pkgname.install
source=("$pkgname::git+http://git.wpitchoune.net/${pkgname%-git}.git"
- 'task-2.5-compat.patch')
+ 'task-2.5.1-compat.patch')
sha512sums=('SKIP'
- 'ffe243097a6580105820fa2ba84b52667ba8d97c34b9e377b54ce297896dbb695fab47d66c634dff724d4c676bf60a83690e5d574b7b34c0b757558f305a6a23')
+ '52f57df194d69b8b1541a9b28af18976bc346ce26c607d28ffcd23fc99df6e463336cb2f176e61199b6b301c477613e0f9a98c1fba9f80aa140ab1b73a2c8aa7')
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
@@ -31,13 +30,11 @@ pkgver() {
prepare() {
cd "$srcdir/$pkgname"
- patch -p1 -i ${srcdir}/task-2.5-compat.patch
+ patch -p1 -i "${srcdir}/task-$(task --version)-compat.patch"
}
build() {
cd "$srcdir/$pkgname"
- aclocal
- automake
./configure \
--prefix=/usr \
--sysconfdir=/usr/share
diff --git a/task-2.5.1-compat.patch b/task-2.5.1-compat.patch
new file mode 100644
index 000000000000..47a01042711e
--- /dev/null
+++ b/task-2.5.1-compat.patch
@@ -0,0 +1,14 @@
+diff --git a/src/tw.c b/src/tw.c
+index 602f7b3..cf10bee 100644
+--- a/src/tw.c
++++ b/src/tw.c
+@@ -116,7 +116,8 @@ static int task_check_version()
+ || !strcmp(ver, "2.3.0")
+ || !strcmp(ver, "2.4.0")
+ || !strcmp(ver, "2.4.1")
+- || !strcmp(ver, "2.5.0"))
++ || !strcmp(ver, "2.5.0")
++ || !strcmp(ver, "2.5.1"))
+ return 1;
+ else
+ return 0;