summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorposcat2025-03-17 09:48:22 +0800
committerposcat2025-03-17 09:49:53 +0800
commit02f6989a6c547c718c93543145509d3dcfe1b4af (patch)
tree9d7014ba1c384281a4f1932b59fe5724bc2f329a
downloadaur-02f6989a6c547c718c93543145509d3dcfe1b4af.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD29
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5578410fe8a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ptcpdump
+ pkgdesc = packet capture tool with process awareness
+ pkgver = 0.33.0
+ pkgrel = 1
+ url = https://github.com/mozillazg/ptcpdump
+ arch = x86_64
+ arch = aarach64
+ license = MIT
+ makedepends = go
+ depends = libpcap
+ depends = glibc
+ source = ptdpdump-0.33.0.tar.gz::https://github.com/mozillazg/ptcpdump/archive/v0.33.0.tar.gz
+ sha256sums = de91ce2150bbfa4ead9da6630dff3fb750c2f1502087103e99123981c8eb4e6b
+
+pkgname = ptcpdump
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3ea09ec85025
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+*.tar.zst
+*.log
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6afe913cefe9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: poscat
+pkgname=ptcpdump
+pkgver=0.33.0
+pkgrel=1
+pkgdesc='packet capture tool with process awareness'
+arch=('x86_64' 'aarach64')
+url='https://github.com/mozillazg/ptcpdump'
+license=('MIT')
+depends=('libpcap' 'glibc')
+makedepends=('go')
+source=("ptdpdump-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('de91ce2150bbfa4ead9da6630dff3fb750c2f1502087103e99123981c8eb4e6b')
+
+build() {
+ cd "${srcdir}"/ptcpdump-${pkgver}
+ go build \
+ -tags dynamic \
+ -buildmode=pie \
+ -mod=readonly \
+ -modcacherw \
+ -trimpath \
+ -ldflags "-linkmode external -extldflags \"${LDFLAGS}\""
+}
+
+package() {
+ cd "${srcdir}"/ptcpdump-${pkgver}
+ install -Dvm755 -t "${pkgdir}"/usr/bin ptcpdump
+ install -Dvm644 -t "${pkgdir}"/usr/share/licenses/${pkgname} LICENSE
+}