summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornulldev2021-05-01 22:40:58 -0400
committernulldev2021-05-01 22:40:58 -0400
commited686e45d7df9ac58014d3f338838ccd828f27b6 (patch)
tree7b8d4605d311242765e402aada6427c329f34a13
parent3fcb4cdd2c4eaab6d5f316e0cf8e652b76930c2d (diff)
downloadaur-ed686e45d7df9ac58014d3f338838ccd828f27b6.tar.gz
Bump version to 1.4.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3872b8790dba..30b2fbd8cb30 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pterodactyl-daemon-bin
pkgdesc = Open-source server control and management daemon for pterodactyl-panel (wings).
- pkgver = 1.4.0
+ pkgver = 1.4.1
pkgrel = 1
url = https://github.com/pterodactyl/wings
arch = x86_64
@@ -10,13 +10,13 @@ pkgbase = pterodactyl-daemon-bin
provides = pterodactyl-daemon
conflicts = pterodactyl-daemon
options = !strip
- source_x86_64 = wings-1.4.0::https://github.com/pterodactyl/wings/releases/download/v1.4.0/wings_linux_amd64
+ source_x86_64 = wings-1.4.1-x86_64::https://github.com/pterodactyl/wings/releases/download/v1.4.1/wings_linux_amd64
source_x86_64 = wings.service
- sha256sums_x86_64 = 4a8e73e1ae5c92963f343577fd92c979f368a7bc0219d330b8510b2bedbd8e5a
+ sha256sums_x86_64 = b8351b81defbf210b26d0a7a52cad77f66cab29722603d5a015880ffe173dc5d
sha256sums_x86_64 = 34429a141df3e257b2396cd56aa6c0df4e3878dc00d42f7651672b4a6bbb0021
- source_aarch64 = wings-1.4.0::https://github.com/pterodactyl/wings/releases/download/v1.4.0/wings_linux_arm64
+ source_aarch64 = wings-1.4.1-aarch64::https://github.com/pterodactyl/wings/releases/download/v1.4.1/wings_linux_arm64
source_aarch64 = wings.service
- sha256sums_aarch64 = 7cfa1344ec54cfca2db1963684d91e7838e57be95380d41ce2eda50f1a77a868
+ sha256sums_aarch64 = 7e91edaa28397b764f4e7f99ef050162ed1666f3bbaf57d1c7ab6c78eb6069fb
sha256sums_aarch64 = 34429a141df3e257b2396cd56aa6c0df4e3878dc00d42f7651672b4a6bbb0021
pkgname = pterodactyl-daemon-bin
diff --git a/PKGBUILD b/PKGBUILD
index ea48428d41ee..2941965a844a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=pterodactyl-daemon-bin
pkgname1=wings
githuborg=pterodactyl
pkgdesc="Open-source server control and management daemon for pterodactyl-panel ($pkgname1)."
-pkgver=1.4.0
+pkgver=1.4.1
pkgrel=1
arch=('x86_64' 'aarch64')
url="https://github.com/$githuborg/$pkgname1"
@@ -12,19 +12,19 @@ conflicts=('pterodactyl-daemon')
provides=('pterodactyl-daemon')
depends=('docker')
options=(!strip)
-source_x86_64=("$pkgname1-$pkgver::$url/releases/download/v$pkgver/wings_linux_amd64" "$pkgname1.service")
-source_aarch64=("$pkgname1-$pkgver::$url/releases/download/v$pkgver/wings_linux_arm64" "$pkgname1.service")
+source_x86_64=("$pkgname1-$pkgver-x86_64::$url/releases/download/v$pkgver/wings_linux_amd64" "$pkgname1.service")
+source_aarch64=("$pkgname1-$pkgver-aarch64::$url/releases/download/v$pkgver/wings_linux_arm64" "$pkgname1.service")
sha256sums_x86_64=(
- '4a8e73e1ae5c92963f343577fd92c979f368a7bc0219d330b8510b2bedbd8e5a'
+ 'b8351b81defbf210b26d0a7a52cad77f66cab29722603d5a015880ffe173dc5d'
'34429a141df3e257b2396cd56aa6c0df4e3878dc00d42f7651672b4a6bbb0021'
)
sha256sums_aarch64=(
- '7cfa1344ec54cfca2db1963684d91e7838e57be95380d41ce2eda50f1a77a868'
+ '7e91edaa28397b764f4e7f99ef050162ed1666f3bbaf57d1c7ab6c78eb6069fb'
'34429a141df3e257b2396cd56aa6c0df4e3878dc00d42f7651672b4a6bbb0021'
)
package() {
mkdir -p "$pkgdir/etc/pterodactyl"
- install -Dm755 "$pkgname1-$pkgver" "$pkgdir/usr/local/bin/$pkgname1"
+ install -Dm755 "$pkgname1-$pkgver-$CARCH" "$pkgdir/usr/local/bin/$pkgname1"
install -Dm644 "$pkgname1.service" -t "$pkgdir/usr/lib/systemd/system/"
}