summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew McGinn2015-11-08 12:16:51 -0500
committerMatthew McGinn2015-11-08 12:16:51 -0500
commitbbce3e9a00990e9ba52c9749e11e1dfd5cdf935c (patch)
treef385682678450e60f15d219a89e705e025e0457e
downloadaur-bbce3e9a00990e9ba52c9749e11e1dfd5cdf935c.tar.gz
Initial commit for ptpd-2.3.1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e89de565500d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Nov 8 17:14:20 UTC 2015
+pkgbase = ptpd
+ pkgdesc = The PTP daemon (PTPd) implements the Precision Time protocol (PTP) as defined by the relevant IEEE 1588 standard. PTP Version 2 implements IEEE-1588-2008. PTP was developed to provide very precise time coordination of LAN connected computers.
+ pkgver = 2.3.1
+ pkgrel = 1
+ url = http://ptpd.sourceforge.net/
+ arch = x86_64
+ arch = i686
+ arch = any
+ license = GPL
+ depends = libpcap
+ provides = ptpd
+ source = http://sourceforge.net/projects/ptpd/files/ptpd/2.3.1/ptpd-2.3.1.tar.gz/download
+ md5sums = 253bab7ab51d969616ea811be1f132f3
+
+pkgname = ptpd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..204f7361e3f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Matthew McGinn <mamcgi@gmail.com>
+pkgname=ptpd
+pkgver=2.3.1
+pkgrel=1
+pkgdesc="The PTP daemon (PTPd) implements the Precision Time protocol (PTP) as defined by the relevant IEEE 1588 standard. PTP Version 2 implements IEEE-1588-2008. PTP was developed to provide very precise time coordination of LAN connected computers."
+arch=('x86_64' 'i686' 'any')
+url="http://ptpd.sourceforge.net/"
+license=('GPL')
+depends=('libpcap')
+provides=('ptpd')
+source=("http://sourceforge.net/projects/ptpd/files/ptpd/2.3.1/ptpd-2.3.1.tar.gz/download")
+md5sums=('253bab7ab51d969616ea811be1f132f3')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr --sbindir=/usr/bin
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}