summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDeedleFake2023-02-22 01:11:34 -0500
committerDeedleFake2023-02-22 01:11:34 -0500
commita31dccb830bdfd4d82cb5c6686c4129a3d38fad4 (patch)
treea04a9f8b9d0c839b7e284d667a4621ed12f30bf6
parentceb4ceeb658189952a89287b0929fbf14840f9dc (diff)
downloadaur-a31dccb830bdfd4d82cb5c6686c4129a3d38fad4.tar.gz
update to v0.7.1
Also fix the permissions to allow ptt-fix to run without being root.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74be79e97f21..15b81dfe009e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = ptt-fix
pkgdesc = A somewhat hacky workaround for push-to-talk in Discord and other apps in Wayland.
- pkgver = 0.7.0
- pkgrel = 2
+ pkgver = 0.7.1
+ pkgrel = 1
url = https://github.com/DeedleFake/ptt-fix
arch = i686
arch = x86_64
license = MIT
makedepends = go>=2:1.20
depends = xdotool
- source = https://github.com/DeedleFake/ptt-fix/archive/refs/tags/v0.7.0.tar.gz
- sha256sums = 8d303630485a2609b89a5a241b29956e184d941c979aa466f43f4469fb66f37e
+ source = https://github.com/DeedleFake/ptt-fix/archive/refs/tags/v0.7.1.tar.gz
+ sha256sums = 47a1c57de707319df88ca06b5e8ac49d53e45fa4ff10a84f79b0a50f0c34b968
pkgname = ptt-fix
diff --git a/PKGBUILD b/PKGBUILD
index e0e049795ce7..3e491743ce63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: DeedleFake <deedlefake@users.noreply.github.com>
pkgname=ptt-fix
-pkgver=0.7.0
-pkgrel=2
+pkgver=0.7.1
+pkgrel=1
pkgdesc="A somewhat hacky workaround for push-to-talk in Discord and other apps in Wayland."
arch=(i686 x86_64)
url="https://github.com/DeedleFake/ptt-fix"
@@ -12,7 +12,7 @@ makedepends=('go>=2:1.20')
optdepends=()
provides=()
source=("https://github.com/DeedleFake/ptt-fix/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('8d303630485a2609b89a5a241b29956e184d941c979aa466f43f4469fb66f37e')
+sha256sums=('47a1c57de707319df88ca06b5e8ac49d53e45fa4ff10a84f79b0a50f0c34b968')
build() {
cd "$pkgname-$pkgver"
@@ -21,7 +21,7 @@ build() {
package() {
cd "$pkgname-$pkgver"
- install -D ptt-fix "$pkgdir/usr/bin/ptt-fix"
+ install -D -m u=rwx,g=srx,o=rx --group input ptt-fix "$pkgdir/usr/bin/ptt-fix"
install -Dm0644 ptt-fix.service "$pkgdir/usr/lib/systemd/user/ptt-fix.service"
}