summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDeedleFake2023-02-17 13:55:23 -0500
committerDeedleFake2023-02-17 13:55:23 -0500
commitadd7f2103a9205a229b7312fdb01081cff7aa70e (patch)
tree68cb44dce163b60143fc1dd55d38732fbb3a1b99
parent160703c105b9b8b8461c68b1aa8d9eac54aa6079 (diff)
downloadaur-add7f2103a9205a229b7312fdb01081cff7aa70e.tar.gz
remove `ptt-fix.service`
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD9
-rw-r--r--ptt-fix.service8
4 files changed, 4 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a916f1060b9d..e0bd8aafb78c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ptt-fix
pkgdesc = A somewhat hacky workaround for push-to-talk in Discord and other apps in Wayland.
pkgver = 0.2.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/DeedleFake/ptt-fix
arch = i686
arch = x86_64
@@ -9,8 +9,6 @@ pkgbase = ptt-fix
makedepends = go>=2:1.20
depends = xdotool
source = https://github.com/DeedleFake/ptt-fix/archive/refs/tags/v0.2.1.tar.gz
- source = ptt-fix.service
sha256sums = 715e236483faa4d8ee39d4874f07b8adca4e2ff5a1e7ee9bf4c00b92a949c023
- sha256sums = f9abe74784cd12709b9f16811e26977fe9f6b306f14777be374b04773d8065b5
pkgname = ptt-fix
diff --git a/.gitignore b/.gitignore
index e95a9bc0ee9c..e1069dfe2844 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,5 +3,3 @@
!PKGBUILD
!.SRCINFO
-
-!ptt-fix.service
diff --git a/PKGBUILD b/PKGBUILD
index 54133aedbef7..a8d245e0ca18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ptt-fix
pkgver=0.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="A somewhat hacky workaround for push-to-talk in Discord and other apps in Wayland."
arch=(i686 x86_64)
url="https://github.com/DeedleFake/ptt-fix"
@@ -11,10 +11,8 @@ depends=(xdotool)
makedepends=('go>=2:1.20')
optdepends=()
provides=()
-source=("https://github.com/DeedleFake/ptt-fix/archive/refs/tags/v${pkgver}.tar.gz"
- ptt-fix.service)
-sha256sums=('715e236483faa4d8ee39d4874f07b8adca4e2ff5a1e7ee9bf4c00b92a949c023'
- 'f9abe74784cd12709b9f16811e26977fe9f6b306f14777be374b04773d8065b5')
+source=("https://github.com/DeedleFake/ptt-fix/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('715e236483faa4d8ee39d4874f07b8adca4e2ff5a1e7ee9bf4c00b92a949c023')
build() {
cd "$pkgname-$pkgver"
@@ -24,7 +22,6 @@ build() {
package() {
cd "$pkgname-$pkgver"
install -D ptt-fix "$pkgdir/usr/bin/ptt-fix"
- install -D "$srcdir/ptt-fix.service" "$pkgdir/usr/lib/systemd/user/ptt-fix.service"
}
# vim: ts=2 sw=2 et
diff --git a/ptt-fix.service b/ptt-fix.service
deleted file mode 100644
index 11164bf4293d..000000000000
--- a/ptt-fix.service
+++ /dev/null
@@ -1,8 +0,0 @@
-[Unit]
-Description=PTT Fix for Wayland
-
-[Service]
-ExecStart=/usr/bin/ptt-fix -key 51 -sym comma
-
-[Install]
-WantedBy=gnome-session-wayland.target