summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorToni Uhlig2018-07-19 16:06:44 +0200
committerToni Uhlig2018-07-19 16:06:44 +0200
commite610864f77dfaa811d5bd13aadfaa8e2e2dc5670 (patch)
tree4a60cbb4af4519d1f1a487147cb6ceae6cef2c72
downloadaur-e610864f77dfaa811d5bd13aadfaa8e2e2dc5670.tar.gz
Initial ptunnel-ng commit.
Signed-off-by: Toni Uhlig <matzeton@googlemail.com>
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..501fa7a5a49b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ptunnel-ng
+ pkgdesc = A TCP forwarder and proxy used for ICMP/UDP tunneling without creating tun devices. (Ping Tunnel, ICMP Echo Tunnel, UDP Tunnel)
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://www.github.com/lnslbrty/ptunnel-ng
+ arch = i686
+ arch = x86_64
+ license = BSD-3
+ makedepends = git
+ provides = ptunnel-ng=1.2
+ source = https://github.com/lnslbrty/ptunnel-ng/archive/v1.2.tar.gz
+ md5sums = 55ea297a34ae35ddc8d5586b15040a15
+
+pkgname = ptunnel-ng
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e79c4583f136
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname="ptunnel-ng"
+pkgver=1.2
+pkgrel=1
+pkgdesc="A TCP forwarder and proxy used for ICMP/UDP tunneling without creating tun devices. (Ping Tunnel, ICMP Echo Tunnel, UDP Tunnel)"
+arch=('i686' 'x86_64')
+url='https://www.github.com/lnslbrty/ptunnel-ng'
+license=('BSD-3')
+makedepends=('git')
+provides=("ptunnel-ng=${pkgver}")
+source=("https://github.com/lnslbrty/ptunnel-ng/archive/v${pkgver}.tar.gz")
+md5sums=('55ea297a34ae35ddc8d5586b15040a15')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --disable-pcap \
+ --disable-selinux
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ find "${pkgdir}" -type d -name .git -exec rm -r '{}' +
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/ptunnel-ng/LICENSE"
+}