summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2017-11-05 18:08:43 +0100
committerFabioLolix2017-11-05 18:08:43 +0100
commit82f2dafe6dc28d49b63b0065f8b0214007a6e404 (patch)
tree9a0b579c667305b7f4ec9e505fad823d768500db
parentbecb50b9c8bf64ce8f7a74a534c7f79e6df36858 (diff)
downloadaur-82f2dafe6dc28d49b63b0065f8b0214007a6e404.tar.gz
Changed launcher
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--ptxconf.sh3
3 files changed, 13 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e658f4b98540..6b1f15aaaf14 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ptxconf-git
pkgdesc = Pen tablet and Touch screen Xinput Configuration tool (PTXConf). Configures touch/pen devices to work with extended desktops and multiple screens on Linux
pkgver = r35.70d2e20
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/wenhsinjen/ptxconf
arch = i686
arch = x86_64
@@ -15,8 +15,10 @@ pkgbase = ptxconf-git
conflicts = ptxconf
source = ptxconf-git::git+https://github.com/wenhsinjen/ptxconf.git
source = ptxconf.desktop
+ source = ptxconf.sh
md5sums = SKIP
md5sums = ea437e99722a1ce37f0893ddac76afe4
+ md5sums = 8ba7d5979171737d9c3b3c809272732f
pkgname = ptxconf-git
diff --git a/PKGBUILD b/PKGBUILD
index 9b9f69489c04..96b00b02d67a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Fabio Loli <loli_fabio@protonmail.com>
+# Maintainer: Fabio Loli <loli_fabio@protonmail.com> -> https://github.com/FabioLolix
pkgname=ptxconf-git
pkgver=r35.70d2e20
-pkgrel=2
+pkgrel=3
pkgdesc="Pen tablet and Touch screen Xinput Configuration tool (PTXConf). Configures touch/pen devices to work with extended desktops and multiple screens on Linux"
arch=('i686' 'x86_64')
url="https://github.com/wenhsinjen/ptxconf"
@@ -12,9 +12,11 @@ makedepends=('git')
provides=('ptxconf')
conflicts=('ptxconf')
source=("${pkgname}::git+https://github.com/wenhsinjen/ptxconf.git"
- 'ptxconf.desktop')
+ 'ptxconf.desktop'
+ 'ptxconf.sh')
md5sums=('SKIP'
- 'ea437e99722a1ce37f0893ddac76afe4')
+ 'ea437e99722a1ce37f0893ddac76afe4'
+ '8ba7d5979171737d9c3b3c809272732f')
pkgver() {
cd ${pkgname}
@@ -24,6 +26,6 @@ pkgver() {
package() {
cd ${srcdir}/${pkgname}
python2 setup.py install --root=${pkgdir}/ --optimize=1
- mv ${pkgdir}/usr/bin/ptxconf.py ${pkgdir}/usr/bin/ptxconf
+ install ${srcdir}/ptxconf.sh ${pkgdir}/usr/bin/ptxconf
install -D ${srcdir}/ptxconf.desktop ${pkgdir}/usr/share/applications/ptxconf.desktop
}
diff --git a/ptxconf.sh b/ptxconf.sh
new file mode 100644
index 000000000000..718f72c280ba
--- /dev/null
+++ b/ptxconf.sh
@@ -0,0 +1,3 @@
+#! /bin/bash
+
+python2 /usr/bin/ptxconf.py