summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralxptt2018-08-12 20:45:05 -0400
committeralxptt2018-08-12 20:45:05 -0400
commit30215e2a180f49a47301b2776e592e86632e2f13 (patch)
tree1128d8321ec5449a8a5fc97981218a60c0013bd4
downloadaur-30215e2a180f49a47301b2776e592e86632e2f13.tar.gz
doing my stuff
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bfdcc4fa4289
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pubip
+ pkgdesc = View your public IP through a number of means
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/alxpettit/pubip
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = bind-tools
+ depends = curl
+ provides = pubip
+ conflicts = pubip
+ source = pubip::git+https://github.com/alxpettit/pubip.git
+ sha256sums = SKIP
+
+pkgname = pubip
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad79f739a5a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintiner: Alexnadria Pettit <alxpettit@gmail.com>
+
+pkgname=pubip
+pkgver=1.0
+pkgrel=1
+pkgdesc="View your public IP through a number of means"
+arch=('any')
+url="https://github.com/alxpettit/pubip"
+license=('GPL')
+depends=('bind-tools' 'curl')
+makedepends=('git')
+provides=('pubip')
+conflicts=('pubip')
+source=("${pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+package() {
+ cd "${pkgname}"
+ install -D -m755 $pkgname "${pkgdir}/usr/bin/$pkgname"
+ #install -D -m755 $pkgname.1 "${pkgdir}/usr/share/man/man1/$pkgname.1"
+}
+