summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkhai96_2020-02-07 23:01:13 +0700
committerkhai96_2020-02-07 23:01:13 +0700
commit30a84708ac9e9b2be02185c38ee9b6b09519045d (patch)
tree3a5c8ad3254246479e52209cd5129eff1478ba54
parent62ca9e1ab927d5054ed62e85d77b05d3af23a9c1 (diff)
downloadaur-30a84708ac9e9b2be02185c38ee9b6b09519045d.tar.gz
Avoid messing up yay cache
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7b3890116e7..7723986933dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,8 +9,8 @@ pkgbase = pueue-bin-2
conflicts = pueue-git
conflicts = pueue
source = https://github.com/Nukesor/pueue/archive/v0.1.6.tar.gz
- source = https://github.com/Nukesor/pueue/releases/download/v0.1.6/pueue-linux-amd64
- source = https://github.com/Nukesor/pueue/releases/download/v0.1.6/pueued-linux-amd64
+ source = pueue-linux-amd64-0.1.6::https://github.com/Nukesor/pueue/releases/download/v0.1.6/pueue-linux-amd64
+ source = pueued-linux-amd64-0.1.6::https://github.com/Nukesor/pueue/releases/download/v0.1.6/pueued-linux-amd64
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f9fc2eea7787..853b36ba5e4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,8 +11,8 @@ provides=('pueue')
url='https://github.com/nukesor/pueue'
source=(
"https://github.com/Nukesor/pueue/archive/v${pkgver}.tar.gz"
- "https://github.com/Nukesor/pueue/releases/download/v${pkgver}/pueue-linux-amd64"
- "https://github.com/Nukesor/pueue/releases/download/v${pkgver}/pueued-linux-amd64"
+ "pueue-linux-amd64-${pkgver}::https://github.com/Nukesor/pueue/releases/download/v${pkgver}/pueue-linux-amd64"
+ "pueued-linux-amd64-${pkgver}::https://github.com/Nukesor/pueue/releases/download/v${pkgver}/pueued-linux-amd64"
)
sha256sums=('SKIP'
'SKIP'
@@ -20,8 +20,8 @@ sha256sums=('SKIP'
package() {
- install -Dm755 "pueue-linux-amd64" "${pkgdir}/usr/bin/pueue"
- install -Dm755 "pueued-linux-amd64" "${pkgdir}/usr/bin/pueued"
+ install -Dm755 "pueue-linux-amd64-${pkgver}" "${pkgdir}/usr/bin/pueue"
+ install -Dm755 "pueued-linux-amd64-${pkgver}" "${pkgdir}/usr/bin/pueued"
tar xf "v${pkgver}.tar.gz"
cd "pueue-${pkgver}"
@@ -31,7 +31,7 @@ package() {
# Install zsh completions file
# Zsh is broken for now
-# install -Dm644 "utils/completions/_pueue" "${pkgdir}/usr/share/zsh/site-functions/_pueue"
+ install -Dm644 "utils/completions/_pueue" "${pkgdir}/usr/share/zsh/site-functions/_pueue"
install -Dm644 "utils/completions/pueue.bash" "${pkgdir}/usr/share/bash-completion/completions/pueue.bash"
install -Dm644 "utils/completions/pueue.fish" "${pkgdir}/usr/share/fish/completions/pueue.fish"