summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Venries2017-02-12 23:11:11 +0100
committerThomas Venries2017-02-12 23:11:17 +0100
commit023c520edf62e7c6e101fa3945d5a73be98bc52d (patch)
tree9f94f2e6882a625166e55dfd1cc5910d6e9bbfc9
downloadaur-023c520edf62e7c6e101fa3945d5a73be98bc52d.tar.gz
release: Added v1.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD17
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..080520f74ff5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pug
+ pkgdesc = Automatically saves Pacman and AUR package lists into Gists.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/Ventto/pug.git
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = make
+ makedepends = git
+ depends = pacman>=5.0
+ depends = gist>=4.5.0
+ source = https://github.com/Ventto/pug/archive/v1.0.tar.gz
+ sha256sums = SKIP
+
+pkgname = pug
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8c3d8558eaf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Thomas "Ventto" Venriès <thomas.venries@gmail.com>
+pkgname='pug'
+pkgver=1.0
+pkgrel=1
+pkgdesc='Automatically saves Pacman and AUR package lists into Gists.'
+arch=('x86_64' 'i686')
+license=('GPL')
+depends=('pacman>=5.0' 'gist>=4.5.0')
+makedepends=('make' 'git')
+url="https://github.com/Ventto/${pkgname}.git"
+source=("https://github.com/Ventto/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}