summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Nader2020-05-27 14:05:25 +0900
committerJason Nader2020-05-27 14:05:25 +0900
commita95b770ad4f7c343b8973de7139e399dea32589c (patch)
tree315b578354f31cc0509d92eae6ac60f251554207
downloadaur-a95b770ad4f7c343b8973de7139e399dea32589c.tar.gz
First commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c173837d345
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pug-hook-git
+ pkgdesc = Automatically saves and synchronizes Pacman and AUR installed package lists into Gists.
+ pkgver = 1.3
+ pkgrel = 1
+ url = https://github.com/Ventto/pug
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = make
+ makedepends = git
+ depends = pacman
+ depends = gist>=4.5.0
+ conflicts = pug
+ source = git+https://github.com/Ventto/pug
+ sha256sums = SKIP
+
+pkgname = pug-hook-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a110f5140dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=pug-hook-git
+_pkgname=pug
+pkgver=20200107.e4bb973
+pkgrel=1
+pkgdesc='Automatically saves and synchronizes Pacman and AUR installed package lists into Gists.'
+arch=('x86_64' 'i686')
+license=('GPL')
+depends=('pacman' 'gist>=4.5.0')
+makedepends=('make' 'git')
+conflicts=('pug')
+url="https://github.com/Ventto/pug"
+source=("git+https://github.com/Ventto/pug")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git log -1 --format='%cd.%h' --date=short | tr -d -
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+}