summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfabrixxm2016-11-27 08:55:37 +0100
committerDavid Vogt2016-11-29 11:05:22 +0100
commit25ac61f46cb706eed1a71dcdefdef340a6cdd008 (patch)
tree7e79781e25651b079396e30200e1cc7e6a7b0304
parent1845d00682bfbdff7101d44cda84522664916897 (diff)
downloadaur-25ac61f46cb706eed1a71dcdefdef340a6cdd008.tar.gz
Install without using virtualenv and pyinstaller
- install required python modules from repository - install pugdebug module in system python's 'site-packages' using provided setup.py and setuptools - install app.py script as /usr/bin/pugdebug - install .desktop file using icon from https://openclipart.org/detail/204954/dog
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD69
-rw-r--r--PugDebug.desktop9
-rw-r--r--setup.py16
4 files changed, 71 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f387e3b12df8..018952d92866 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,22 @@
pkgbase = pugdebug-git
- pkgdesc = pugdebug is a standalone debugging client for PHP applications that uses XDebug as the debugging engine
+ pkgdesc = PugDebug is a standalone debugging client for PHP applications that uses XDebug as the debugging engine
pkgver = v1.0.0.r20.g00859c3
- pkgrel = 1
+ pkgrel = 2
url = http://pugdebug.com/
arch = any
license = GPL3
- makedepends = git
- depends = python
- depends = pyinstaller
- depends = python-virtualenv
- depends = python-six
+ depends = python>=3.4
+ depends = python-pyqt5
+ depends = python-pygments
provides = pugdebug
source = pugdebug-git::git://github.com/robertbasic/pugdebug.git
- source = LICENSE::https://raw.githubusercontent.com/robertbasic/pugdebug/master/COPYING
- sha256sums = SKIP
- sha256sums = c61f12da7cdad526bdcbed47a4c0a603e60dbbfdaf8b66933cd088e9132c303f
+ source = setup.py
+ source = PugDebug.desktop
+ source = https://openclipart.org/image/256px/svg_to_png/204954/dog.png
+ md5sums = SKIP
+ md5sums = 7556a53bc966e1fd2a51ac8d7f61220f
+ md5sums = 0a6f0a35199b4b0eccbd5291b180e553
+ md5sums = 4a382fe99a6d4e9fafc5a047af77402b
pkgname = pugdebug-git
diff --git a/PKGBUILD b/PKGBUILD
index c0988cef0b5c..918eb50c89e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,53 +1,52 @@
-# Maintainer: David Vogt <dave at winged dot ch>
# This PKGBUILD is maintained at https://github.com/winged/aur-packages
+# Dog icon by ecuabron ( https://openclipart.org/detail/204954/dog )
+
+# Contributor: Fabio Comuni <fabrixxm@kirgroup.com>
+# Maintainer: David Vogt <dave at winged dot ch>
pkgname=pugdebug-git
_pkgname=pugdebug-git
pkgver=v1.0.0.r20.g00859c3
-pkgrel=1
-pkgdesc=" pugdebug is a standalone debugging client for PHP applications that uses XDebug as the debugging engine"
+pkgrel=2
+pkgdesc="PugDebug is a standalone debugging client for PHP applications that uses XDebug as the debugging engine"
arch=('any')
license=('GPL3')
-url='http://pugdebug.com/'
-depends=('python'
- 'pyinstaller'
- 'python-virtualenv'
- 'python-six')
+url="http://pugdebug.com/"
+depends=('python>=3.4' 'python-pyqt5' 'python-pygments')
conflicts=()
provides=('pugdebug')
-makedepends=('git')
-source=("$pkgname::git://github.com/robertbasic/pugdebug.git"
- "LICENSE::https://raw.githubusercontent.com/robertbasic/pugdebug/master/COPYING")
-sha256sums=('SKIP' 'c61f12da7cdad526bdcbed47a4c0a603e60dbbfdaf8b66933cd088e9132c303f')
+make_depends=('git' 'python-setuptools')
+source=("$pkgname::git://github.com/robertbasic/pugdebug.git"
+ setup.py
+ PugDebug.desktop
+ https://openclipart.org/image/256px/svg_to_png/204954/dog.png)
-if [ -n "$VIRTUAL_ENV" ]; then
- echo "Warning: You're building within a virtualenv. Use"
- echo "a shell without virtualenv to build this package!"
- exit 1
-fi
+md5sums=('SKIP'
+ '7556a53bc966e1fd2a51ac8d7f61220f'
+ '0a6f0a35199b4b0eccbd5291b180e553'
+ '4a382fe99a6d4e9fafc5a047af77402b')
pkgver() {
cd "$_pkgname"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cp "${srcdir}/setup.py" "${srcdir}/${_pkgname}/"
+ sed -i "s|:version:|${pkgver}|" "${srcdir}/${_pkgname}/setup.py"
}
package() {
- pwd
- cd "$_pkgname"
-
- # Patch in missing deps
- echo six >> requirements.txt
- echo pyqt5 >> requirements.txt
-
- virtualenv env
- source env/bin/activate
- pip install -r requirements.txt
-
- bash ./build.sh
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
- install -Dm755 dist/pugdebug $pkgdir/usr/bin/pugdebug
-
+ install -D -m655 "${srcdir}/PugDebug.desktop" "$pkgdir/usr/share/applications/PugDebug.desktop"
+
+ install -D -m655 ${srcdir}/dog.png "$pkgdir/usr/share/pixmaps/pugdebug.png"
+
+ cd "${srcdir}/${_pkgname}"
+ python setup.py install --root="${pkgdir}"
+
+ sed -i 's|#! python|#!/usr/bin/env python3|' app.py
+ install -TD app.py "${pkgdir}/usr/bin/pugdebug"
+
+ install -D -m655 LICENSE "${pkgdir}/usr/share/pugdebug/LICENSE"
+ install -D -m655 COPYING "${pkgdir}/usr/share/pugdebug/COPYING"
}
-
-# vim:set ts=2 sw=2 et:
diff --git a/PugDebug.desktop b/PugDebug.desktop
new file mode 100644
index 000000000000..1422222fed5c
--- /dev/null
+++ b/PugDebug.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=PugDebug
+Comment=A standalone debugging client for PHP applications.
+Exec=/usr/bin/pugdebug
+Icon=/usr/share/pixmaps/pugdebug.png
+Terminal=false
+Type=Application
+Categories=Qt;Development;Debugger;
diff --git a/setup.py b/setup.py
new file mode 100644
index 000000000000..ab7784519b20
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,16 @@
+import os
+from setuptools import setup, find_packages
+
+def read(fname):
+ return open(os.path.join(os.path.dirname(__file__), fname)).read()
+
+setup(
+ name = "pugdebug",
+ version = ":version:",
+ author = "robertbasic",
+ description = ("A standalone debugging client for PHP applications."),
+ license = "GPLv3+",
+ url = "https://github.com/robertbasic/pugdebug",
+ packages=find_packages(),
+ long_description=read('README.md'),
+)