summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Vogt2016-05-13 13:40:58 +0200
committerDavid Vogt2016-05-13 13:40:58 +0200
commit7b2219e8bd5712c57f219416f1d39257375b9c84 (patch)
tree34fcc26528d79b1cba55ae32830e340bbb331be4
downloadaur-7b2219e8bd5712c57f219416f1d39257375b9c84.tar.gz
Initial version
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD53
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c467822d2e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pugdebug-git
+ pkgdesc = pugdebug is a standalone debugging client for PHP applications that uses XDebug as the debugging engine
+ pkgver = v1.0.0.r20.g00859c3
+ pkgrel = 1
+ url = http://github.com/neovim/python-client
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python
+ depends = pyinstaller
+ depends = python-virtualenv
+ depends = python-six
+ provides = pugdebug
+ source = pugdebug-git::git://github.com/robertbasic/pugdebug.git
+ source = LICENSE::https://raw.githubusercontent.com/robertbasic/pugdebug/master/COPYING
+ sha256sums = SKIP
+ sha256sums = c61f12da7cdad526bdcbed47a4c0a603e60dbbfdaf8b66933cd088e9132c303f
+
+pkgname = pugdebug-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f1bcf3641805
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+pkg/
+python2-neovim-git-*.pkg.*
+python2-neovim-git/
+src/
+pugdebug-git
+LICENSE
+pugdebug-git-*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1401c69330cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: David Vogt <dave at winged dot ch>
+# This PKGBUILD is maintained at https://github.com/winged/aur-packages
+
+pkgname=pugdebug-git
+_pkgname=pugdebug-git
+pkgver=v1.0.0.r20.g00859c3
+pkgrel=1
+pkgdesc=" pugdebug is a standalone debugging client for PHP applications that uses XDebug as the debugging engine"
+arch=('any')
+license=('GPL3')
+url='http://github.com/neovim/python-client'
+depends=('python'
+ 'pyinstaller'
+ 'python-virtualenv'
+ 'python-six')
+conflicts=()
+provides=('pugdebug')
+makedepends=('git')
+source=("$pkgname::git://github.com/robertbasic/pugdebug.git"
+ "LICENSE::https://raw.githubusercontent.com/robertbasic/pugdebug/master/COPYING")
+sha256sums=('SKIP' 'c61f12da7cdad526bdcbed47a4c0a603e60dbbfdaf8b66933cd088e9132c303f')
+
+if [ -n "$VIRTUAL_ENV" ]; then
+ echo "Warning: You're building within a virtualenv. Use"
+ echo "a shell without virtualenv to build this package!"
+ exit 1
+fi
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ pwd
+ cd "$_pkgname"
+
+ # Patch in missing deps
+ echo six >> requirements.txt
+ echo pyqt5 >> requirements.txt
+
+ virtualenv env
+ source env/bin/activate
+ pip install -r requirements.txt
+
+ bash ./build.sh
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -Dm755 dist/pugdebug $pkgdir/usr/bin/pugdebug
+
+}
+
+# vim:set ts=2 sw=2 et: