summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgileri2020-10-30 18:11:41 +0100
committergileri2020-10-30 18:11:41 +0100
commitc62a610830297165864cd36232ecd2932762578e (patch)
tree8aebe324d4ef0508cb115ac9c27da468928815b8
parent25ac61f46cb706eed1a71dcdefdef340a6cdd008 (diff)
downloadaur-c62a610830297165864cd36232ecd2932762578e.tar.gz
Switch to Mte90 active fork
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 018952d92866..751f74c471d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,19 @@
pkgbase = pugdebug-git
pkgdesc = PugDebug is a standalone debugging client for PHP applications that uses XDebug as the debugging engine
- pkgver = v1.0.0.r20.g00859c3
- pkgrel = 2
- url = http://pugdebug.com/
+ pkgver = 1.1.0.r1.gddb1193
+ pkgrel = 1
+ url = https://github.com/mte90/pugdebug
arch = any
license = GPL3
- depends = python>=3.4
+ makedepends = python-setuptools
+ depends = python>=3.7
depends = python-pyqt5
depends = python-pygments
+ depends = flake8
+ depends = python-fuzzywuzzy
+ depends = python-levenshtein
provides = pugdebug
- source = pugdebug-git::git://github.com/robertbasic/pugdebug.git
+ source = pugdebug-git::git://github.com/Mte90/pugdebug.git
source = setup.py
source = PugDebug.desktop
source = https://openclipart.org/image/256px/svg_to_png/204954/dog.png
diff --git a/PKGBUILD b/PKGBUILD
index 918eb50c89e3..4712d95cec07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
-# This PKGBUILD is maintained at https://github.com/winged/aur-packages
# Dog icon by ecuabron ( https://openclipart.org/detail/204954/dog )
# Contributor: Fabio Comuni <fabrixxm@kirgroup.com>
-# Maintainer: David Vogt <dave at winged dot ch>
+# Contributor: David Vogt <dave at winged dot ch>
+# Maintainer: Éric Gillet <e + aur2419 at linuxw dot info>
pkgname=pugdebug-git
_pkgname=pugdebug-git
-pkgver=v1.0.0.r20.g00859c3
-pkgrel=2
+pkgver=1.1.0.r1.gddb1193
+pkgrel=1
pkgdesc="PugDebug is a standalone debugging client for PHP applications that uses XDebug as the debugging engine"
arch=('any')
license=('GPL3')
-url="http://pugdebug.com/"
-depends=('python>=3.4' 'python-pyqt5' 'python-pygments')
+url='https://github.com/mte90/pugdebug'
+depends=('python>=3.7' 'python-pyqt5' 'python-pygments' 'flake8' 'python-fuzzywuzzy' 'python-levenshtein')
conflicts=()
provides=('pugdebug')
-make_depends=('git' 'python-setuptools')
-source=("$pkgname::git://github.com/robertbasic/pugdebug.git"
+makedepends=('python-setuptools')
+source=("$pkgname::git://github.com/Mte90/pugdebug.git"
setup.py
PugDebug.desktop
https://openclipart.org/image/256px/svg_to_png/204954/dog.png)
@@ -33,7 +33,6 @@ pkgver() {
build() {
cp "${srcdir}/setup.py" "${srcdir}/${_pkgname}/"
- sed -i "s|:version:|${pkgver}|" "${srcdir}/${_pkgname}/setup.py"
}
package() {
@@ -44,7 +43,6 @@ package() {
cd "${srcdir}/${_pkgname}"
python setup.py install --root="${pkgdir}"
- sed -i 's|#! python|#!/usr/bin/env python3|' app.py
install -TD app.py "${pkgdir}/usr/bin/pugdebug"
install -D -m655 LICENSE "${pkgdir}/usr/share/pugdebug/LICENSE"