summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjonian2022-11-12 16:54:15 +0200
committerjonian2022-11-12 16:54:15 +0200
commit04070a1fd40f1fe60434e501a9d79b40773c356e (patch)
tree652c9261838f28b3661fdcc559c3922b85b4747b
parent17ebea0c05dfce0308e3d234ab740f97035e7ea8 (diff)
downloadaur-04070a1fd40f1fe60434e501a9d79b40773c356e.tar.gz
fix core packages not loading in settings view
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8857d891b3f7..f18d2d2b52d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pulsar-bin
pkgdesc = Community build of the hackable text editor, built on Electron
pkgver = 1.63.2022111116
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/pulsar-edit/pulsar
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 150c0200530a..71a388b54e8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ _datetag=2022111116
pkgname="${_appname}-bin"
pkgver="1.63.${_datetag}"
-pkgrel=1
+pkgrel=2
pkgdesc="Community build of the hackable text editor, built on Electron"
arch=("x86_64")
url="https://github.com/${_reponame}/${_appname}"
@@ -38,6 +38,9 @@ package() {
find "$pkgdir/opt/Pulsar/resources/app/ppm" -type d -name "spec" -exec rm -rf {} +
find "$pkgdir/opt/Pulsar/resources/app.asar.unpacked" -type d -name "spec" -exec rm -rf {} +
+ # Fix core modules missing in settings. Remove when implemented upstream
+ sed -i "s/=== 'apm'/=== 'ppm'/" "$pkgdir/opt/Pulsar/resources/app/ppm/lib/apm.js"
+
# This needs removal along with asar makedepend when fixed upstream
mkdir -p "$pkgdir/opt/Pulsar/resources/app.asar.unpacked/node_modules/github/"
mv asar/node_modules/github/bin "$pkgdir/opt/Pulsar/resources/app.asar.unpacked/node_modules/github/bin"