summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChiwan Park2020-05-05 23:03:32 +0900
committerChiwan Park2020-05-05 23:03:32 +0900
commit4dee206d4d7f61a45113f0da3dc8d02413c2e105 (patch)
tree9cc70a16669a48fb7d491f8c30a710fee5dbd727
parent586335f7d754ad4e48a57d3b2cd5086677c98932 (diff)
downloadaur-4dee206d4d7f61a45113f0da3dc8d02413c2e105.tar.gz
Fix bug in runner script
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--PulseClient-Arch.patch21
3 files changed, 24 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11900a513ca7..e65a4c5ff1d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pulse-secure
pkgdesc = Pulse Connect Secure (PCS) Client
pkgver = 9.1r5.0_b151
- pkgrel = 1
+ pkgrel = 2
url = https://www.pulsesecure.net/
arch = x86_64
license = custom
@@ -15,7 +15,7 @@ pkgbase = pulse-secure
source = PulseClient-Arch.patch
md5sums = d81155461e2666c2b9d669c1b76f85fe
md5sums = 261848a28201e5386ec4bf587473a48b
- md5sums = 67032face47b5675efec02382172bb55
+ md5sums = 26f0e8c97a4a47db7d1b9c06dcdb5f90
source_x86_64 = https://wiki.univ-nantes.fr/_media/nomade:pulse_clients:ps-pulse-linux-9.1r5.0-b151-centos-rhel-64-bit-installer.rpm
md5sums_x86_64 = ebcdb7a371cf016d6a41b6f81e60db6d
diff --git a/PKGBUILD b/PKGBUILD
index 7a4ca234b9a1..d224d964d2bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=pulse-secure
pkgver=9.1r5.0_b151
-pkgrel=1
+pkgrel=2
pkgdesc='Pulse Connect Secure (PCS) Client'
arch=(x86_64)
license=(custom)
@@ -14,7 +14,7 @@ source=(pulseUi.sh
source_x86_64=("https://wiki.univ-nantes.fr/_media/nomade:pulse_clients:ps-pulse-linux-${pkgver/_/-}-centos-rhel-64-bit-installer.rpm")
md5sums=('d81155461e2666c2b9d669c1b76f85fe'
'261848a28201e5386ec4bf587473a48b'
- '7c1fdf76c3e1eee9e6a4a387ae3f3a6b')
+ '26f0e8c97a4a47db7d1b9c06dcdb5f90')
md5sums_x86_64=('ebcdb7a371cf016d6a41b6f81e60db6d')
optdepends=('webkitgtk: for pulseUi frontend'
'psmisc: for pulsesvc -K')
diff --git a/PulseClient-Arch.patch b/PulseClient-Arch.patch
index 8ac064488267..00930da4b276 100644
--- a/PulseClient-Arch.patch
+++ b/PulseClient-Arch.patch
@@ -1,5 +1,5 @@
--- usr/local/pulse/PulseClient_x86_64.sh 2020-04-03 15:17:07.000000000 +0900
-+++ usr/local/pulse/PulseClient_x86_64.sh.new 2020-04-29 10:55:49.149374568 +0900
++++ usr/local/pulse/PulseClient_x86_64.sh.new 2020-05-05 22:51:10.170118991 +0900
@@ -17,7 +17,7 @@
SCRNAME=`basename $0`
@@ -18,3 +18,22 @@
else
OSNAME=$(lsb_release -d | grep -o "Ubuntu")
if [ "X$OSNAME" != "X" ]; then
+@@ -355,7 +357,7 @@
+ isRpmBased=1
+ elif [[ ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$UBUNTU_14]}) || \
+ ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$UBUNTU_15]}) || \
+- ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$UBUNTU_16_17_18_19]}) || \
++ ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$UBUNTU_16_17_18]}) || \
+ ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$UBUNTU_19]}) || \
+ ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$DEBIAN_10]}) || \
+ ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$DEBIAN_8_9]}) ]]; then
+@@ -430,7 +432,8 @@
+ RPM_DIST=1
+ elif [[ ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$UBUNTU_14]}) || \
+ ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$UBUNTU_15]}) || \
+- ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$UBUNTU_16_17_18_19]}) || \
++ ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$UBUNTU_16_17_18]}) || \
++ ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$UBUNTU_19]}) || \
+ ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$DEBIAN_8_9]}) ]]; then
+ DPKG_DIST=1
+ fi