summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChiwan Park2021-02-06 21:01:23 +0900
committerChiwan Park2021-02-24 19:16:02 +0900
commita47daccbbc96d63cfa0ef81060301fda7fba22bd (patch)
treea66ba7a48fb7d2181aead7f6ef7142e336b5be4f
parent0224806926ce66180afef21558d53705f89fa0c3 (diff)
downloadaur-a47daccbbc96d63cfa0ef81060301fda7fba22bd.tar.gz
Upgrade to 9.1r10.0_b5655
- Refactor install script for totally rewritten clients - Add note message to notify pulsesecure.service
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD78
-rw-r--r--PulseClient-Arch.patch39
-rw-r--r--pulse-secure.install25
-rw-r--r--pulseUi.sh4
5 files changed, 63 insertions, 98 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abcdcf430f02..9ad1cda1bb7f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,22 @@
pkgbase = pulse-secure
pkgdesc = Pulse Connect Secure (PCS) Client
- pkgver = 9.1r9.0_b255
+ pkgver = 9.1r10.0_b5655
pkgrel = 1
url = https://www.pulsesecure.net/
+ install = pulse-secure.install
arch = x86_64
license = custom
depends = gcc-libs
depends = libgnome-keyring
- optdepends = webkitgtk: for pulseUi frontend
+ depends = openssl
+ depends = curl
+ depends = dbus
optdepends = psmisc: for pulsesvc -K
conflicts = pulse-connect-secure
- source = pulseUi.sh
source = EULA.txt
- source = PulseClient-Arch.patch
- md5sums = d81155461e2666c2b9d669c1b76f85fe
md5sums = 261848a28201e5386ec4bf587473a48b
- md5sums = 2748e1b68097d297e3ac58ca893d0b61
- source_x86_64 = http://webdev.web3.technion.ac.il/docs/cis/public/ssl-vpn/v.9.1R9.0/ps-pulse-linux-9.1r9.0-b255-centos-rhel-64-bit-installer.rpm
- md5sums_x86_64 = f727a1d286baba9311be2bc6a7e77293
+ source_x86_64 = https://vubnet.vub.ac.be/downloads/pulsesecure-9.1-R10.x86_64.rpm
+ md5sums_x86_64 = 7b20971904493da9da3de130df00ecc3
pkgname = pulse-secure
diff --git a/PKGBUILD b/PKGBUILD
index f36fbff2c9c3..66173d43c24b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,61 +1,45 @@
# Maintainer: Chiwan Park <chiwanpark@hotmail.com>
pkgname=pulse-secure
-pkgver=9.1r9.0_b255
+pkgver=9.1r10.0_b5655
pkgrel=1
pkgdesc='Pulse Connect Secure (PCS) Client'
arch=(x86_64)
license=(custom)
url='https://www.pulsesecure.net/'
-depends=(gcc-libs libgnome-keyring)
-source=(pulseUi.sh
- EULA.txt
- PulseClient-Arch.patch)
-source_x86_64=("http://webdev.web3.technion.ac.il/docs/cis/public/ssl-vpn/v.9.1R9.0/ps-pulse-linux-${pkgver/_/-}-centos-rhel-64-bit-installer.rpm")
-md5sums=('d81155461e2666c2b9d669c1b76f85fe'
- '261848a28201e5386ec4bf587473a48b'
- '2748e1b68097d297e3ac58ca893d0b61')
-md5sums_x86_64=('f727a1d286baba9311be2bc6a7e77293')
-optdepends=('webkitgtk: for pulseUi frontend'
- 'psmisc: for pulsesvc -K')
+depends=(gcc-libs libgnome-keyring openssl curl dbus)
+install=${pkgname}.install
+source=(EULA.txt)
+source_x86_64=("https://vubnet.vub.ac.be/downloads/pulsesecure-9.1-R10.x86_64.rpm")
+md5sums=('261848a28201e5386ec4bf587473a48b')
+md5sums_x86_64=('7b20971904493da9da3de130df00ecc3')
+optdepends=('psmisc: for pulsesvc -K')
conflicts=(pulse-connect-secure)
-prepare() {
- patch -Np0 -i ./PulseClient-Arch.patch
-
- mkdir -p pulse && cd pulse
- tar -zxvf ../usr/local/pulse/pulse.tgz
-}
-
-# adapted from ConfigurePulse_x86_64.sh
-update_build_info() {
- pkgdir=$1
-
- INSTALLDIR="$pkgdir"/usr/local/pulse
-
- BUILD_VERSION=${pkgver%_b*}
- BUILD_NUMBER=${pkgver#*_b}
-
- sed -i "s/BUILD_VERSION/${BUILD_VERSION}/g" "${INSTALLDIR}/html/about.html"
- sed -i "s/BUILD_NUMBER/${BUILD_NUMBER}/g" "${INSTALLDIR}/html/about.html"
-}
-
package() {
- install -Dm755 usr/local/pulse/PulseClient_x86_64.sh "$pkgdir"/usr/local/pulse/PulseClient_x86_64.sh
- install -Dm644 usr/local/pulse/{README,version.txt} "$pkgdir"/usr/local/pulse/
- install -Dm755 pulse/pulseutil "$pkgdir"/usr/local/pulse/
- install -Dm4755 pulse/pulsesvc "$pkgdir"/usr/local/pulse/
- install -Dm755 pulse/pulseUi_centos_7_x86_64 "$pkgdir"/usr/local/pulse/pulseUi
- install -Dm755 pulse/libpulseui.so_centos_7_x86_64 "$pkgdir"/usr/local/pulse/libpulseui.so
- install -Dm644 pulse/pulseUi.desktop "$pkgdir"/usr/share/applications/pulseUi.desktop
-
- # Wrappers & symlinks
- install -Dm755 pulseUi.sh "$pkgdir"/usr/bin/pulseUi
- ln -s /usr/local/pulse/pulsesvc "$pkgdir"/usr/bin/pulsesvc
-
- cp -dr --no-preserve=ownership pulse/html "$pkgdir"/usr/local/pulse/html
-
install -Dm644 EULA.txt "$pkgdir"/usr/share/licenses/$pkgname/EULA.txt
- update_build_info "$pkgdir"
+ for d in $(find opt/pulsesecure -type d); do
+ install -dm755 "$d" "$pkgdir"/"$d";
+ done
+ for f in $(find opt/pulsesecure/bin -type f); do
+ install -Dm755 "$f" "$pkgdir"/"$f";
+ done
+ for f in $(find opt/pulsesecure/lib -type f); do
+ install -Dm755 "$f" "$pkgdir"/"$f";
+ done
+ for f in $(find opt/pulsesecure/resource -type f); do
+ install -Dm644 "$f" "$pkgdir"/"$f";
+ done
+ install -Dm644 usr/share/man/man1/pulse.1.gz "$pkgdir"/usr/share/man/man1/pulse.1.gz
+
+ # we move service unit file to /usr/lib/systemd/system due to pacman limitation
+ install -Dm644 lib/systemd/system/pulsesecure.service "$pkgdir"/usr/lib/systemd/system/pulsesecure.service
+
+ mkdir -p "$pkgdir"/usr/share/applications/ "$pkgdir"/usr/share/dbus-1/system.d/ "$pkgdir"/opt/pulsesecure/lib/JUNS/interfaces
+ ln -s /opt/pulsesecure/resource/pulse.desktop "$pkgdir"/usr/share/applications/pulse.desktop
+ ln -s /opt/pulsesecure/lib/JUNS/net.psecure.pulse.conf "$pkgdir"/usr/share/dbus-1/system.d/net.psecure.pulse.conf
+ for f in $(find opt/pulsesecure/lib/JUNS/interfaces -type l); do
+ ln -s $(readlink $f) "$pkgdir"/"$f" ;
+ done
}
diff --git a/PulseClient-Arch.patch b/PulseClient-Arch.patch
deleted file mode 100644
index b5b7f33458fa..000000000000
--- a/PulseClient-Arch.patch
+++ /dev/null
@@ -1,39 +0,0 @@
---- usr/local/pulse/PulseClient_x86_64.sh 2020-04-03 15:17:07.000000000 +0900
-+++ usr/local/pulse/PulseClient_x86_64.sh.new 2020-05-05 22:51:10.170118991 +0900
-@@ -17,7 +17,7 @@
-
- SCRNAME=`basename $0`
-
--SUPPORTED_OSTYPES_LIST=( CENTOS_6 CENTOS_7 CENTOS_8 UBUNTU_14 UBUNTU_15 UBUNTU_16_17_18 UBUNTU_19 FEDORA FEDORA_30 FEDORA_31 FEDORA_32 RHEL_7 RHEL_8 DEBIAN_8_9 DEBIAN_10 THINPRO_7 UNSUPPORTED)
-+SUPPORTED_OSTYPES_LIST=( ARCH CENTOS_6 CENTOS_7 CENTOS_8 UBUNTU_14 UBUNTU_15 UBUNTU_16_17_18 UBUNTU_19 FEDORA FEDORA_30 FEDORA_31 FEDORA_32 RHEL_7 RHEL_8 DEBIAN_8_9 DEBIAN_10 THINPRO_7 UNSUPPORTED)
- #RPM Based
- CENTOS_6_DEPENDENCIES=( glibc \
- nss-softokn-freebl \
-@@ -305,6 +305,8 @@
- else
- OS_TYPE=${SUPPORTED_OSTYPES_LIST[$UNSUPPORTED]}
- fi
-+ elif [ -f /etc/arch-release ]; then
-+ OS_TYPE=${SUPPORTED_OSTYPES_LIST[$ARCH]}
- else
- OSNAME=$(lsb_release -d | grep -o "Ubuntu")
- if [ "X$OSNAME" != "X" ]; then
-@@ -355,7 +357,7 @@
- isRpmBased=1
- elif [[ ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$UBUNTU_14]}) || \
- ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$UBUNTU_15]}) || \
-- ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$UBUNTU_16_17_18_19]}) || \
-+ ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$UBUNTU_16_17_18]}) || \
- ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$UBUNTU_19]}) || \
- ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$DEBIAN_10]}) || \
- ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$DEBIAN_8_9]}) ]]; then
-@@ -430,7 +432,8 @@
- RPM_DIST=1
- elif [[ ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$UBUNTU_14]}) || \
- ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$UBUNTU_15]}) || \
-- ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$UBUNTU_16_17_18_19]}) || \
-+ ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$UBUNTU_16_17_18]}) || \
-+ ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$UBUNTU_19]}) || \
- ($OS_TYPE = ${SUPPORTED_OSTYPES_LIST[$DEBIAN_8_9]}) ]]; then
- DPKG_DIST=1
- fi
diff --git a/pulse-secure.install b/pulse-secure.install
new file mode 100644
index 000000000000..61faf8fae6e2
--- /dev/null
+++ b/pulse-secure.install
@@ -0,0 +1,25 @@
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+post_install() {
+ note "From 9.1r10.0, the client (pulseUi, pulselauncher) requires a service called pulsesecure."
+ note "Run 'sudo systemctl start pulsesecure' before you run the client"
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ systemctl stop pulsesecure.service
+}
diff --git a/pulseUi.sh b/pulseUi.sh
deleted file mode 100644
index ed7ecedbb84c..000000000000
--- a/pulseUi.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-
-export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/pulse
-exec /usr/local/pulse/pulseUi