summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChiwan Park2024-05-19 13:01:09 +0900
committerChiwan Park2024-05-19 13:01:09 +0900
commitc6ce3d42e9a87f38e4936a0c30282c435d39df4e (patch)
tree4cf13d7833494845d54c0791a5d263adcf3d8010
parentab47c304aee12766e1a4d539f8a81d5aa95244a3 (diff)
downloadaur-c6ce3d42e9a87f38e4936a0c30282c435d39df4e.tar.gz
Use system-installed shasum instead of hard-coded one
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--setup_cef.sh.patch11
3 files changed, 18 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab07415be037..eab122bd6802 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pulse-secure
pkgdesc = Ivanti Secure Access Client
pkgver = 22.7r1.0_b28369
- pkgrel = 1
+ pkgrel = 2
url = https://www.pulsesecure.net/
install = pulse-secure.install
arch = x86_64
@@ -18,7 +18,9 @@ pkgbase = pulse-secure
optdepends = webkit2gtk: for pulseUi
conflicts = pulse-connect-secure
source = EULA.txt
+ source = setup_cef.sh.patch
md5sums = 261848a28201e5386ec4bf587473a48b
+ md5sums = 31c0e4d462053b189274b8f6df340525
source_x86_64 = https://descargas.grancanaria.com/Sistemas/PulseSecureClients/ps-pulse-linux-22.7r1.0-b28369-64bit-installer.rpm
md5sums_x86_64 = b6ef3316547b22a22d81a26c2cf16d3b
diff --git a/PKGBUILD b/PKGBUILD
index e6dd2bd619e5..da1753da5585 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,16 @@ DLAGENTS=("https::/usr/bin/curl -k -o %o %u")
pkgname=pulse-secure
pkgver=22.7r1.0_b28369
-pkgrel=1
+pkgrel=2
pkgdesc='Ivanti Secure Access Client'
arch=(x86_64)
license=(custom)
url='https://www.pulsesecure.net/'
depends=(gcc-libs libgnome-keyring openssl curl dbus libbsd dmidecode)
install=${pkgname}.install
-source=(EULA.txt)
+source=("EULA.txt" "setup_cef.sh.patch")
source_x86_64=("https://descargas.grancanaria.com/Sistemas/PulseSecureClients/ps-pulse-linux-22.7r1.0-b28369-64bit-installer.rpm")
-md5sums=('261848a28201e5386ec4bf587473a48b')
+md5sums=('261848a28201e5386ec4bf587473a48b' '31c0e4d462053b189274b8f6df340525')
md5sums_x86_64=('b6ef3316547b22a22d81a26c2cf16d3b')
optdepends=('psmisc: for pulsesvc -K', 'gtkmm3: for pulseUi', 'webkit2gtk: for pulseUi')
conflicts=(pulse-connect-secure)
@@ -23,6 +23,7 @@ package() {
for d in $(find opt/pulsesecure -type d); do
install -dm755 "$d" "$pkgdir"/"$d";
done
+ patch opt/pulsesecure/bin/setup_cef.sh setup_cef.sh.patch
for f in $(find opt/pulsesecure/bin -type f); do
install -Dm755 "$f" "$pkgdir"/"$f";
done
diff --git a/setup_cef.sh.patch b/setup_cef.sh.patch
new file mode 100644
index 000000000000..074ab4f68d08
--- /dev/null
+++ b/setup_cef.sh.patch
@@ -0,0 +1,11 @@
+--- setup_cef.sh 2024-05-19 12:44:48.627275977 +0900
++++ setup_cef.sh.new 2024-05-19 12:45:10.434819102 +0900
+@@ -119,7 +119,7 @@
+ DATE=$(full_path_command "date")
+ GREP=$(full_path_command "grep")
+ AWK=$(full_path_command "awk")
+-SHASUM=$(full_path_command "shasum")
++SHASUM=$(which "shasum")
+ TR=$(full_path_command "tr")
+ BASE64=$(full_path_command "base64")
+ CUT=$(full_path_command "cut")