summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwhight2018-12-11 00:56:21 -0800
committerwhight2018-12-11 00:56:21 -0800
commiteacca9add37b47d45bee7809ed8f0ebe537b8e99 (patch)
tree27a875ea5f26815c87a4b32f17b96455b10410f8
parentecbeccef959f6d1b228b933a9055cb2575536328 (diff)
downloadaur-eacca9add37b47d45bee7809ed8f0ebe537b8e99.tar.gz
Added license, symlink to bin
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9385ae3b2a61..69363e59ec28 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = pulse-sms
pkgdesc = A native desktop implementation of Pulse
pkgver = 3.1.4
- pkgrel = 1
+ pkgrel = 2
url = https://messenger.klinkerapps.com/
arch = x86_64
+ license = APACHE
depends = gconf
depends = libnotify
depends = libxtst
diff --git a/PKGBUILD b/PKGBUILD
index f08a101c7b4d..f97fff1c82ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
-# Maintainer: whight
+# Maintainer: whight
pkgname="pulse-sms"
pkgver="3.1.4"
-pkgrel=1
+pkgrel=2
pkgdesc="A native desktop implementation of Pulse"
arch=('x86_64')
url="https://messenger.klinkerapps.com/"
+license=('APACHE')
depends=('gconf' 'libnotify' 'libxtst' 'nss' 'libxss')
source=(
@@ -17,4 +18,9 @@ sha512sums=(
package() {
tar -xf data.tar.xz -C "$pkgdir"
+ mv "${pkgdir}/opt/Pulse SMS/" "${pkgdir}/opt/${pkgname}"
+
+ # install alias in /usr/bin
+ mkdir "${pkgdir}/usr/bin"
+ ln -s "/opt/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
}