summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMr. Tao2020-08-29 21:14:38 +0200
committerMr. Tao2020-08-29 21:14:38 +0200
commitb25a80d69517067a38df839a5102f1f377c6d8df (patch)
tree41edd2eca9f1af713992ce811c9de60d94d5a87a
parentb6676fce2f291b4d3ccdfc8a5240a24ce027ac02 (diff)
downloadaur-b25a80d69517067a38df839a5102f1f377c6d8df.tar.gz
Rebase on the current upstream version
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD18
2 files changed, 23 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbf8d9f0973..bc7832cc51c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pulseaudio-airplay
pkgdesc = A featureful, general-purpose sound server
- pkgver = 13.99.1+98+g317fd09b7
+ pkgver = 13.99.1+104+gcc93eb360
pkgrel = 1
url = https://www.freedesktop.org/wiki/Software/PulseAudio/
arch = x86_64
@@ -32,14 +32,14 @@ pkgbase = pulseaudio-airplay
makedepends = git
makedepends = meson
makedepends = xmltoman
- source = git+https://gitlab.freedesktop.org/mr-tao/pulseaudio.git#commit=317fd09b72e3c33ecdbffaecc00fd6ff0c1a7e74
+ source = git+https://gitlab.freedesktop.org/mr-tao/pulseaudio.git#commit=cc93eb360afeafb9bc8ac72c0511894aaa647769
source = 0001-meson-Define-TUNNEL_SINK-for-module-tunnel-sink.patch
sha256sums = SKIP
sha256sums = 4ff133e2847baad5bb6798b5816d67551cfba2efabb2f1f348628d7217abd07d
pkgname = pulseaudio-airplay
install = pulseaudio.install
- depends = libpulse-airplay=13.99.1+98+g317fd09b7-1
+ depends = libpulse-airplay=13.99.1+104+gcc93eb360-1
depends = rtkit
depends = libltdl
depends = speexdsp
@@ -48,7 +48,7 @@ pkgname = pulseaudio-airplay
depends = libsoxr
depends = webrtc-audio-processing
optdepends = pulseaudio-alsa: ALSA configuration (recommended)
- provides = pulseaudio
+ provides = pulseaudio=13.99.1
conflicts = pulseaudio
replaces = pulseaudio-xen<=9.0
replaces = pulseaudio-gconf<=11.1
@@ -74,42 +74,42 @@ pkgname = libpulse-airplay
pkgname = pulseaudio-airplay-zeroconf
pkgdesc = Zeroconf support for PulseAudio
- depends = pulseaudio-airplay=13.99.1+98+g317fd09b7-1
+ depends = pulseaudio-airplay=13.99.1+104+gcc93eb360-1
depends = avahi
depends = openssl
- provides = pulseaudio-zeroconf
+ provides = pulseaudio-zeroconf=13.99.1
conflicts = pulseaudio-zeroconf
pkgname = pulseaudio-airplay-lirc
pkgdesc = IR (lirc) support for PulseAudio
- depends = pulseaudio-airplay=13.99.1+98+g317fd09b7-1
+ depends = pulseaudio-airplay=13.99.1+104+gcc93eb360-1
depends = lirc
- provides = pulseaudio-lirc
+ provides = pulseaudio-lirc=13.99.1
conflicts = pulseaudio-lirc
pkgname = pulseaudio-airplay-jack
pkgdesc = Jack support for PulseAudio
- depends = pulseaudio-airplay=13.99.1+98+g317fd09b7-1
+ depends = pulseaudio-airplay=13.99.1+104+gcc93eb360-1
depends = jack
- provides = pulseaudio-jack
+ provides = pulseaudio-jack=13.99.1
conflicts = pulseaudio-jack
pkgname = pulseaudio-airplay-bluetooth
pkgdesc = Bluetooth support for PulseAudio
- depends = pulseaudio-airplay=13.99.1+98+g317fd09b7-1
+ depends = pulseaudio-airplay=13.99.1+104+gcc93eb360-1
depends = bluez
depends = bluez-libs
depends = sbc
- provides = pulseaudio-bluetooth
+ provides = pulseaudio-bluetooth=13.99.1
conflicts = pulseaudio-bluetooth
pkgname = pulseaudio-airplay-equalizer
pkgdesc = Equalizer for PulseAudio
- depends = pulseaudio-airplay=13.99.1+98+g317fd09b7-1
+ depends = pulseaudio-airplay=13.99.1+104+gcc93eb360-1
depends = python-pyqt5
depends = python-dbus
depends = python-sip
depends = fftw
- provides = pulseaudio-equalizer
+ provides = pulseaudio-equalizer=13.99.1
conflicts = pulseaudio-equalizer
diff --git a/PKGBUILD b/PKGBUILD
index 622e33200aa..556b5cd9fb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=(pulseaudio-airplay libpulse-airplay pulseaudio-airplay-{zeroconf,lirc,jack,bluetooth,equalizer})
pkgdesc="A featureful, general-purpose sound server"
-pkgver=13.99.1+98+g317fd09b7
+pkgver=13.99.1+104+gcc93eb360
pkgrel=1
arch=(x86_64)
url="https://www.freedesktop.org/wiki/Software/PulseAudio/"
@@ -15,7 +15,7 @@ makedepends=(libasyncns libcap attr libxtst libsm libsndfile rtkit libsoxr
speexdsp tdb systemd dbus avahi bluez bluez-libs jack2 sbc
lirc openssl fftw orc gtk3 webrtc-audio-processing check git meson
xmltoman)
-_commit=317fd09b72e3c33ecdbffaecc00fd6ff0c1a7e74 # tags/v13.0^0
+_commit=cc93eb360afeafb9bc8ac72c0511894aaa647769 # tags/v13.99.1
source=("git+https://gitlab.freedesktop.org/mr-tao/pulseaudio.git#commit=$_commit"
0001-meson-Define-TUNNEL_SINK-for-module-tunnel-sink.patch)
sha256sums=('SKIP'
@@ -60,7 +60,7 @@ _pick() {
}
package_pulseaudio-airplay() {
- provides=(pulseaudio)
+ provides=('pulseaudio=13.99.1')
conflicts=(pulseaudio)
depends=("libpulse-airplay=$pkgver-$pkgrel" rtkit libltdl speexdsp tdb orc libsoxr
webrtc-audio-processing)
@@ -134,7 +134,7 @@ package_pulseaudio-airplay() {
}
package_libpulse-airplay() {
- provides=(libpulse)
+ provides=('libpulse=13.99.1')
conflicts=(libpulse)
pkgdesc="$pkgdesc (client library)"
depends=(dbus libasyncns libcap libxtst libsm libsndfile systemd)
@@ -146,7 +146,7 @@ package_libpulse-airplay() {
}
package_pulseaudio-airplay-zeroconf(){
- provides=(pulseaudio-zeroconf)
+ provides=('pulseaudio-zeroconf=13.99.1')
conflicts=(pulseaudio-zeroconf)
pkgdesc="Zeroconf support for PulseAudio"
depends=("pulseaudio-airplay=$pkgver-$pkgrel" avahi openssl)
@@ -155,7 +155,7 @@ package_pulseaudio-airplay-zeroconf(){
}
package_pulseaudio-airplay-lirc(){
- provides=(pulseaudio-lirc)
+ provides=('pulseaudio-lirc=13.99.1')
conflicts=(pulseaudio-lirc)
pkgdesc="IR (lirc) support for PulseAudio"
depends=("pulseaudio-airplay=$pkgver-$pkgrel" lirc)
@@ -164,7 +164,7 @@ package_pulseaudio-airplay-lirc(){
}
package_pulseaudio-airplay-jack(){
- provides=(pulseaudio-jack)
+ provides=('pulseaudio-jack=13.99.1')
conflicts=(pulseaudio-jack)
pkgdesc="Jack support for PulseAudio"
depends=("pulseaudio-airplay=$pkgver-$pkgrel" jack)
@@ -173,7 +173,7 @@ package_pulseaudio-airplay-jack(){
}
package_pulseaudio-airplay-bluetooth(){
- provides=(pulseaudio-bluetooth)
+ provides=('pulseaudio-bluetooth=13.99.1')
conflicts=(pulseaudio-bluetooth)
pkgdesc="Bluetooth support for PulseAudio"
depends=("pulseaudio-airplay=$pkgver-$pkgrel" bluez bluez-libs sbc)
@@ -182,7 +182,7 @@ package_pulseaudio-airplay-bluetooth(){
}
package_pulseaudio-airplay-equalizer(){
- provides=(pulseaudio-equalizer)
+ provides=('pulseaudio-equalizer=13.99.1')
conflicts=(pulseaudio-equalizer)
pkgdesc="Equalizer for PulseAudio"
depends=("pulseaudio-airplay=$pkgver-$pkgrel" python-{pyqt5,dbus,sip} fftw)