summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcopygirl2018-02-02 22:18:02 +0100
committercopygirl2018-02-02 22:18:02 +0100
commit339bfec5f7b9345815b43bcb1ceaee32d981fdf0 (patch)
tree93a6c53e197fea14da68eb473c2dd024fe796c5a
downloadaur-339bfec5f7b9345815b43bcb1ceaee32d981fdf0.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--90-pulseaudio-arctis7.rules1
-rw-r--r--PKGBUILD28
-rw-r--r--steelseries-arctis-input.conf25
-rw-r--r--steelseries-arctis-output-mono.conf30
-rw-r--r--steelseries-arctis-output-stereo.conf27
-rw-r--r--steelseries-arctis-usb-audio.conf43
7 files changed, 174 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6962924a6843
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pulseaudio-arctis7
+ pkgdesc = Configuration files to support SteelSeries Arctis 7 mono/stereo output on pulseaudio
+ pkgver = 1.0
+ pkgrel = 1
+ arch = any
+ license = LGPL
+ depends = pulseaudio
+ source = 90-pulseaudio-arctis7.rules
+ source = steelseries-arctis-input.conf
+ source = steelseries-arctis-output-mono.conf
+ source = steelseries-arctis-output-stereo.conf
+ source = steelseries-arctis-usb-audio.conf
+ md5sums = 6a489d6877963b7260b5e63e4348a360
+ md5sums = 2a68f9d0ee3a89c47d0c7781c8f46ce0
+ md5sums = 0134ec266ddef9a1d4bcfc206b6bcc1d
+ md5sums = e8ca5d47324c9b0504e131e9919e109d
+ md5sums = b16786cf6b6fd16fe54fbd5770db7447
+
+pkgname = pulseaudio-arctis7
+
diff --git a/90-pulseaudio-arctis7.rules b/90-pulseaudio-arctis7.rules
new file mode 100644
index 000000000000..022c2309e8f5
--- /dev/null
+++ b/90-pulseaudio-arctis7.rules
@@ -0,0 +1 @@
+SUBSYSTEM!="sound", ACTION!="change", KERNEL!="card*", SUBSYSTEMS=="usb", ATTRS{idVendor}=="1038", ATTRS{idProduct}=="1260", ENV{PULSE_PROFILE_SET}="steelseries-arctis-usb-audio.conf"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de0832b5dfb3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: copygirl <copygirl@mcft.net>
+pkgname=pulseaudio-arctis7
+pkgver=1.0
+pkgrel=1
+pkgdesc="Configuration files to support SteelSeries Arctis 7 mono/stereo output on pulseaudio"
+arch=("any")
+license=("LGPL")
+depends=("pulseaudio")
+options=()
+source=("90-pulseaudio-arctis7.rules"
+ "steelseries-arctis-input.conf"
+ "steelseries-arctis-output-mono.conf"
+ "steelseries-arctis-output-stereo.conf"
+ "steelseries-arctis-usb-audio.conf")
+md5sums=("6a489d6877963b7260b5e63e4348a360"
+ "2a68f9d0ee3a89c47d0c7781c8f46ce0"
+ "0134ec266ddef9a1d4bcfc206b6bcc1d"
+ "e8ca5d47324c9b0504e131e9919e109d"
+ "b16786cf6b6fd16fe54fbd5770db7447")
+
+package() {
+ install -dm 755 ${pkgdir}/usr/{udev/rules.d,share/pulseaudio/alsa-mixer/{paths,profile-sets}}
+ install -Dm 644 90-pulseaudio-arctis7.rules ${pkgdir}/usr/udev/rules.d/
+ install -Dm 644 steelseries-arctis-input.conf ${pkgdir}/usr/share/pulseaudio/alsa-mixer/paths
+ install -Dm 644 steelseries-arctis-output-mono.conf ${pkgdir}/usr/share/pulseaudio/alsa-mixer/paths
+ install -Dm 644 steelseries-arctis-output-stereo.conf ${pkgdir}/usr/share/pulseaudio/alsa-mixer/paths
+ install -Dm 644 steelseries-arctis-usb-audio.conf ${pkgdir}/usr/share/pulseaudio/alsa-mixer/profile-sets
+}
diff --git a/steelseries-arctis-input.conf b/steelseries-arctis-input.conf
new file mode 100644
index 000000000000..f3115ba6657d
--- /dev/null
+++ b/steelseries-arctis-input.conf
@@ -0,0 +1,25 @@
+# This file is part of PulseAudio.
+#
+# PulseAudio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2.1 of the
+# License, or (at your option) any later version.
+#
+# PulseAudio is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.
+
+; Steelseries Arctis 7 USB headset microphone path.
+
+[General]
+description-key = analog-input-microphone-headset
+
+[Element Headset]
+volume = merge
+switch = mute
+override-map.1 = all
+override-map.2 = all-left,all-right
diff --git a/steelseries-arctis-output-mono.conf b/steelseries-arctis-output-mono.conf
new file mode 100644
index 000000000000..faeb327b65d0
--- /dev/null
+++ b/steelseries-arctis-output-mono.conf
@@ -0,0 +1,30 @@
+# This file is part of PulseAudio.
+#
+# PulseAudio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2.1 of the
+# License, or (at your option) any later version.
+#
+# PulseAudio is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.
+
+; Steelseries Arctis 7 USB headset mono output path. The headset has two
+; output devices. The first one is mono, meant for voice audio, and the
+; second one is stereo, meant for everything else. The purpose of this
+; unusual design is to provide separate volume controls for voice and
+; other audio, which can be useful in gaming.
+
+[General]
+# description-key = analog-output-headphones-mono
+description = Headset Mono Output
+
+[Element PCM]
+volume = merge
+switch = mute
+override-map.1 = all
+override-map.2 = all-left,all-right
diff --git a/steelseries-arctis-output-stereo.conf b/steelseries-arctis-output-stereo.conf
new file mode 100644
index 000000000000..4e10c8005981
--- /dev/null
+++ b/steelseries-arctis-output-stereo.conf
@@ -0,0 +1,27 @@
+# This file is part of PulseAudio.
+#
+# PulseAudio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2.1 of the
+# License, or (at your option) any later version.
+#
+# PulseAudio is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.
+
+; Steelseries Arctis 7 USB headset stereo output path. The headset has two
+; output devices. The first one is mono, meant for voice audio, and the
+; second one is stereo, meant for everything else. The purpose of this
+; unusual design is to provide separate volume controls for voice and
+; other audio, which can be useful in gaming.
+;
+; This path doesn't provide hardware volume control, because the stereo
+; output is controlled by the PCM element with index 1, and currently
+; PulseAudio only supports elements with index 0.
+
+[General]
+description-key = analog-output-headphones
diff --git a/steelseries-arctis-usb-audio.conf b/steelseries-arctis-usb-audio.conf
new file mode 100644
index 000000000000..d3563a16065e
--- /dev/null
+++ b/steelseries-arctis-usb-audio.conf
@@ -0,0 +1,43 @@
+# This file is part of PulseAudio.
+#
+# PulseAudio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2.1 of the
+# License, or (at your option) any later version.
+#
+# PulseAudio is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.
+
+; Steelseries Arctis 7 USB headset. The headset has a microphone and two output
+; devices. The first output device is mono, meant for voice audio, and the
+; second one is stereo, meant for everything else. The purpose of this unusual
+; design is to provide separate volume controls for voice and other audio,
+; which can be useful in gaming.
+;
+; See default.conf for an explanation on the directives used here.
+
+[General]
+auto-profiles = yes
+
+[Mapping analog-mono]
+device-strings = hw:%f,0,0
+channel-map = mono
+paths-output = steelseries-arctis-output-mono
+paths-input = steelseries-arctis-input
+
+[Mapping analog-stereo]
+device-strings = hw:%f,1,0
+channel-map = left,right
+paths-output = steelseries-arctis-output-stereo
+direction = output
+
+[Profile output:analog-mono+output:analog-stereo+input:analog-mono]
+output-mappings = analog-mono analog-stereo
+input-mappings = analog-mono
+priority = 5100
+skip-probe = yes