summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Bartels2016-10-22 16:52:27 +0200
committerPatrick Bartels2016-10-22 16:52:27 +0200
commitbef1169d32960a753cd01ffc30722c4776a022f7 (patch)
treeb54b6d2079251023d15fa62e512d141dcb5344eb
downloadaur-bef1169d32960a753cd01ffc30722c4776a022f7.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bb8a0d0d1abd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pulseaudio-module-sndio
+ pkgdesc = Pulseaudio module for sndio support
+ pkgver = r10.0a732e0
+ pkgrel = 1
+ url = https://github.com/t6/pulseaudio-module-sndio
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = pulseaudio
+ depends = sndio
+ source = pulseaudio-module-sndio::git+https://github.com/t6/pulseaudio-module-sndio.git#commit=0a732e03309c0a8b1632286a46bdc39733845f68
+ md5sums = SKIP
+
+pkgname = pulseaudio-module-sndio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26f342cab84e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Contributor: Patrick Bartels <pckbls@gmail.com>
+
+pkgname=pulseaudio-module-sndio
+pkgdesc="Pulseaudio module for sndio support"
+pkgver=r10.0a732e0
+pkgrel=1
+arch=(i686 x86_64)
+url="https://github.com/t6/pulseaudio-module-sndio"
+license=(BSD)
+depends=(pulseaudio sndio)
+source=("$pkgname::git+https://github.com/t6/pulseaudio-module-sndio.git#commit=0a732e03309c0a8b1632286a46bdc39733845f68")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+package(){
+ cd "$pkgname"
+ STAGEDIR="$pkgdir" make install
+}
+