summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkballen2019-10-16 19:52:51 +0000
committerkballen2019-10-16 19:52:51 +0000
commitff33d0dcf10ae3ac190297c580c1a7a9d3a6c48b (patch)
treebb9d1f2ddd5b1f0bb35e6a8823931b839a371c6e
downloadaur-ff33d0dcf10ae3ac190297c580c1a7a9d3a6c48b.tar.gz
v0.3 - Initial version
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD45
-rw-r--r--xrdp-script.conf2
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4f296fed6e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pulseaudio-module-xrdp
+ pkgdesc = PulseAudio modules for xrdp
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://github.com/neutrinolabs/pulseaudio-module-xrdp
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ depends = pulseaudio
+ depends = xrdp
+ source = pulseaudio-module-xrdp-0.3.tar.gz::https://github.com/neutrinolabs/pulseaudio-module-xrdp/archive/v0.3.tar.gz
+ source = git+https://github.com/pulseaudio/pulseaudio.git
+ source = xrdp-script.conf
+ sha256sums = 11ebe426a93b3a22eeffe460ec643cabe33061757b6b2db5fa8807b2788e1e30
+ sha256sums = SKIP
+ sha256sums = 4c6e9c0b1eaf66ea6b8574570d89b292b8554d318ad324f3763f837013b9f44f
+
+pkgname = pulseaudio-module-xrdp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f33ef51c97f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: kballen <ken@kballentine.net>
+
+pkgname=pulseaudio-module-xrdp
+pkgver=0.3
+pkgrel=1
+pkgdesc="PulseAudio modules for xrdp"
+arch=('i686' 'x86_64')
+url="https://github.com/neutrinolabs/pulseaudio-module-xrdp"
+license=('Apache')
+depends=('pulseaudio' 'xrdp')
+makedepends=('git')
+
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/neutrinolabs/${pkgname}/archive/v${pkgver}.tar.gz"
+ "git+https://github.com/pulseaudio/pulseaudio.git"
+ "xrdp-script.conf")
+sha256sums=('11ebe426a93b3a22eeffe460ec643cabe33061757b6b2db5fa8807b2788e1e30'
+ 'SKIP'
+ '4c6e9c0b1eaf66ea6b8574570d89b292b8554d318ad324f3763f837013b9f44f')
+
+prepare() {
+ cd "$srcdir/pulseaudio"
+ git checkout v`pkg-config libpulse --modversion|sed 's/[^0-9.]*\([0-9.]*\).*/\1/'`
+ NOCONFIGURE=1 ./bootstrap.sh
+ ./configure
+}
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ ./bootstrap
+ ./configure "PULSE_DIR=$srcdir/pulseaudio"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+
+ # This package installs a global drop-in conf for pulseaudio.service to use the xrdp default.pa script instead of
+ # the script from the pulseaudio package. If your only desktop sessions will be via xrdp, this should be fine. But
+ # if you want to start local sessions too, this will prevent the real audio devices from being detected. If this is
+ # a problem for you, delete the drop-in conf file and roll your own solution for loading the xrdp modules for xrdp
+ # sessions only (maybe add PULSE_SCRIPT to the user systemd's environment in startwm.sh and create a drop-in for
+ # pulseaudio.service that adds PassEnvironment=PULSE_SCRIPT).
+ install -Dm644 "$srcdir"/xrdp-script.conf "$pkgdir"/usr/lib/systemd/user/pulseaudio.service.d/xrdp-script.conf
+}
diff --git a/xrdp-script.conf b/xrdp-script.conf
new file mode 100644
index 000000000000..beb893ab169f
--- /dev/null
+++ b/xrdp-script.conf
@@ -0,0 +1,2 @@
+[Service]
+Environment=PULSE_SCRIPT=/etc/xrdp/pulse/default.pa