summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJat2021-08-20 18:45:56 +0800
committerJat2021-08-20 18:45:56 +0800
commit7facaf8fecadececa76231293e16d95125cf01dd (patch)
tree8fff9e20081fa352002bb78e95ee874fcaf3eff4
parent84edbbde6b16910718f8001a2c115108601b51cc (diff)
downloadaur-7facaf8fecadececa76231293e16d95125cf01dd.tar.gz
pulseaudio 15
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD50
-rw-r--r--pulseaudio-module-xrdp.install9
-rw-r--r--xrdp-script.conf2
5 files changed, 48 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c13f83bd784..0d3e48c4517c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,24 @@
pkgbase = pulseaudio-module-xrdp-git
pkgdesc = PulseAudio modules for xrdp
- pkgver = 0.4.r4.ge9f78c4
+ pkgver = 0.5.r2.g8b3c7f3
pkgrel = 1
url = https://github.com/neutrinolabs/pulseaudio-module-xrdp
+ install = pulseaudio-module-xrdp.install
arch = i686
arch = x86_64
- license = Apache
+ license = LGPL
makedepends = git
+ makedepends = meson
+ makedepends = check
+ makedepends = doxygen
+ makedepends = perl-xml-parser
depends = pulseaudio
depends = xrdp
provides = pulseaudio-module-xrdp
conflicts = pulseaudio-module-xrdp
- source = pulseaudio-module-xrdp-git::git+https://github.com/neutrinolabs/pulseaudio-module-xrdp.git#branch=devel
- source = git+https://github.com/pulseaudio/pulseaudio.git
- source = xrdp-script.conf
+ source = git+https://github.com/neutrinolabs/pulseaudio-module-xrdp.git#branch=devel
+ source = https://freedesktop.org/software/pulseaudio/releases/pulseaudio-15.0.tar.xz
sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = 4c6e9c0b1eaf66ea6b8574570d89b292b8554d318ad324f3763f837013b9f44f
+ sha256sums = a40b887a3ba98cc26976eb11bdb6613988f145b19024d1b6555c6a03c9cba1a0
pkgname = pulseaudio-module-xrdp-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bb24d62c7d0d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!pulseaudio-module-xrdp.install
diff --git a/PKGBUILD b/PKGBUILD
index 820091e6ef68..81a158619eaf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,50 @@
# Maintainer: kballen <ken@kballentine.net>
-pkgname=pulseaudio-module-xrdp-git
-pkgver=0.4.r4.ge9f78c4
+_pkgname=pulseaudio-module-xrdp
+pkgname="${_pkgname}-git"
+pkgver=0.5.r2.g8b3c7f3
pkgrel=1
pkgdesc="PulseAudio modules for xrdp"
arch=('i686' 'x86_64')
url="https://github.com/neutrinolabs/pulseaudio-module-xrdp"
-license=('Apache')
+license=('LGPL')
depends=('pulseaudio' 'xrdp')
-makedepends=('git')
+makedepends=('git' 'meson' 'check' 'doxygen' 'perl-xml-parser')
+install="${_pkgname}.install"
conflicts=('pulseaudio-module-xrdp')
provides=('pulseaudio-module-xrdp')
-source=("$pkgname::git+https://github.com/neutrinolabs/pulseaudio-module-xrdp.git#branch=devel"
- "git+https://github.com/pulseaudio/pulseaudio.git"
- "xrdp-script.conf")
+_pulseaudio_ver=$(pulseaudio --version | awk '{print $NF}')
+source=("git+https://github.com/neutrinolabs/${_pkgname}.git#branch=devel"
+ "https://freedesktop.org/software/pulseaudio/releases/pulseaudio-${_pulseaudio_ver}.tar.xz")
sha256sums=('SKIP'
- 'SKIP'
- '4c6e9c0b1eaf66ea6b8574570d89b292b8554d318ad324f3763f837013b9f44f')
+ $(curl -fs "https://freedesktop.org/software/pulseaudio/releases/pulseaudio-${_pulseaudio_ver}.tar.xz.sha256sum" | awk '{print $1}'))
pkgver() {
- cd "$srcdir/$pkgname"
- git describe --tags --long|sed -E 's,^[^0-9]*,,;s,([0-9]*-g),r\1,;s,-,.,g'
+ cd "$srcdir/$_pkgname"
+
+ git describe --long --tags | sed -E 's,^[^0-9]*,,;s,([0-9]*-g),r\1,;s,-,.,g'
}
prepare() {
- cd "$srcdir/pulseaudio"
- git checkout v`pkg-config libpulse --modversion|sed 's/[^0-9.]*\([0-9.]*\).*/\1/'`
- NOCONFIGURE=1 ./bootstrap.sh
- ./configure
+ cd "$srcdir/pulseaudio-${_pulseaudio_ver}"
+
+ meson build
+ meson compile -C build
}
build() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/${_pkgname}"
+
+ sed -i '\#-I $(PULSE_DIR)/src#a -I $(PULSE_DIR)/build \\' src/Makefile.am
+
./bootstrap
- ./configure "PULSE_DIR=$srcdir/pulseaudio"
+ ./configure "PULSE_DIR=$srcdir/pulseaudio-${_pulseaudio_ver}"
make
}
package() {
- cd "$srcdir/$pkgname"
- make DESTDIR="$pkgdir" install
+ cd "$srcdir/${_pkgname}"
- # This package installs a global drop-in conf for pulseaudio.service to use the xrdp default.pa script instead of
- # the script from the pulseaudio package. If your only desktop sessions will be via xrdp, this should be fine. But
- # if you want to start local sessions too, this will prevent the real audio devices from being detected. If this is
- # a problem for you, delete the drop-in conf file and roll your own solution for loading the xrdp modules for xrdp
- # sessions only (maybe add PULSE_SCRIPT to the user systemd's environment in startwm.sh and create a drop-in for
- # pulseaudio.service that adds PassEnvironment=PULSE_SCRIPT).
- install -Dm644 "$srcdir"/xrdp-script.conf "$pkgdir"/usr/lib/systemd/user/pulseaudio.service.d/xrdp-script.conf
+ make DESTDIR="$pkgdir" install
}
diff --git a/pulseaudio-module-xrdp.install b/pulseaudio-module-xrdp.install
new file mode 100644
index 000000000000..5de9a9a9a65a
--- /dev/null
+++ b/pulseaudio-module-xrdp.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo -e '\033[0;31mRemember to pass the environment' \
+ '"PULSE_SCRIPT=/etc/xrdp/pulse/default.pa" to pulseaudio' \
+ 'to make this module work.\033[0m'
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/xrdp-script.conf b/xrdp-script.conf
deleted file mode 100644
index beb893ab169f..000000000000
--- a/xrdp-script.conf
+++ /dev/null
@@ -1,2 +0,0 @@
-[Service]
-Environment=PULSE_SCRIPT=/etc/xrdp/pulse/default.pa