summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhayao2021-01-19 19:42:32 +0900
committerhayao2021-01-19 19:42:32 +0900
commit71b1ce682eab04297461b87ba93090032ad11255 (patch)
tree7cceae8ddeec13164d1c97eba3655a89482844ba
parent904dc12671bb5eea007454e8f3561e41e315f24c (diff)
downloadaur-71b1ce682eab04297461b87ba93090032ad11255.tar.gz
[fix] : pulseaudio version
-rw-r--r--.SRCINFO8
-rwxr-xr-xPKGBUILD25
2 files changed, 13 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9270d6ae147..9c621b877d8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pulseaudio-modules-bt
pkgdesc = PulseAudio Bluetooth modules with SBC, AAC, APTX, APTX-HD, Sony LDAC (A2DP codec) support
- pkgver = 1.4_14.1
- pkgrel = 3
+ pkgver = 1.4_14.2
+ pkgrel = 4
url = https://github.com/EHfive/pulseaudio-modules-bt
arch = i686
arch = x86_64
@@ -21,11 +21,11 @@ pkgbase = pulseaudio-modules-bt
depends = libfdk-aac.so
optdepends = libavcodec.so>=58: aptX Classic, aptX HD support
optdepends = libldac: LDAC support
- optdepends = pulseaudio=14.1: This package requires a specific PulseAudio version
+ optdepends = pulseaudio=14.2: This package requires a specific PulseAudio version
provides = pulseaudio-bluetooth
conflicts = pulseaudio-bluetooth
source = pulseaudio-modules-bt-1.4.zip::https://github.com/EHfive/pulseaudio-modules-bt/archive/v1.4.zip
- source = pulseaudio-14.1.zip::https://github.com/pulseaudio/pulseaudio/archive/v14.1.zip
+ source = pulseaudio-14.2.zip::https://github.com/pulseaudio/pulseaudio/archive/v14.2.zip
md5sums = 711a7f930321e56706acdb441de0e432
md5sums = SKIP
sha512sums = 5c3ed59dec46a1a9cc2f359ac1d28a82a50a5dea47a268a10601b95a8e17a68dd00ba7628c429271349bae290f461abeb1a4a3715b1833c71d7f82f9a902fe2d
diff --git a/PKGBUILD b/PKGBUILD
index 6ab25dc7eed6..91b35e498685 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,24 +4,12 @@
#-- PulseAudio --#
pulseaudio_pkgname="pulseaudio"
-if pacman -Qq "$(basename "${pulseaudio_pkgname}")" 2> "/dev/null" 1>&2; then
- # If pulseaudio is installed, use the version of installed pulseaudio.
- pulseaudio_ver="$(pacman -Q "$(basename "${pulseaudio_pkgname}")" | cut -d ' ' -f 2 | cut -d '-' -f 1)"
-else
- # If pulseaudio is not installed, use the version from offcial repository.
- pulseaudio_ver="$(pacman -Sp --print-format '%v' "${pulseaudio_pkgname}" | cut -d '-' -f 1)"
-fi
-
-# if it is failed to get the version of pulseaudio, use the hard coded one.
-if [[ -z "${pulseaudio_ver}" ]]; then
- pulseaudio_ver="14.1"
-fi
-
+pulseaudio_ver="$(pacman -Q "$(basename "${pulseaudio_pkgname}")" | cut -d ' ' -f 2 | cut -d '-' -f 1)"
pkgname="pulseaudio-modules-bt"
module_ver="1.4"
pkgver="${module_ver}_${pulseaudio_ver}"
-pkgrel="3"
+pkgrel="4"
pkgdesc="PulseAudio Bluetooth modules with SBC, AAC, APTX, APTX-HD, Sony LDAC (A2DP codec) support"
arch=("i686" "x86_64" "arm" "armv6h" "armv7h" "aarch64")
url="https://github.com/EHfive/pulseaudio-modules-bt"
@@ -59,13 +47,18 @@ prepare() {
build() {
cd "${srcdir}/pulseaudio-modules-bt-${module_ver}"
+ rm -rf build
+ mkdir build
+ cd build
cmake \
-DCMAKE_BUILD_TYPE=Release \
- .
+ -S .. \
+ -B . \
+
make
}
package() {
- cd "$srcdir/pulseaudio-modules-bt-${module_ver}"
+ cd "${srcdir}/pulseaudio-modules-bt-${module_ver}/build"
make DESTDIR="${pkgdir}" install
}