summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEHfive2018-09-10 20:42:12 +0800
committerEHfive2018-09-10 20:42:12 +0800
commitfc2dbe05cb3f33a188c82971a436991dca8e61e3 (patch)
tree47ea4dce31698c71d0f5140007b45afec6909997
parent188863e24626766db0d81950d1cc8b940951cc8a (diff)
downloadaur-fc2dbe05cb3f33a188c82971a436991dca8e61e3.tar.gz
update
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c38600bcdc6f..52cd8fd6ed90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pulseaudio-modules-bt-git
pkgdesc = PulseAudio Bluetooth modules with Sony LDAC Codec(A2DP Source) support
- pkgver = r25.2d97ce7
+ pkgver = r26.cc65a46
pkgrel = 1
url = https://github.com/EHfive/pulseaudio-modules-bt
arch = i686
@@ -9,6 +9,7 @@ pkgbase = pulseaudio-modules-bt-git
license = GPL3
makedepends = cmake>=3.0
makedepends = make
+ makedepends = pkg-config
depends = pulseaudio>=12.0
depends = libpulse>=12.0
depends = bluez>=5.0
@@ -19,7 +20,7 @@ pkgbase = pulseaudio-modules-bt-git
replaces = pulseaudio-bluetooth
source = git+https://github.com/EHfive/pulseaudio-modules-bt.git
source = git+https://github.com/pulseaudio/pulseaudio.git
- source = git+https://android.googlesource.com/platform/external/libldac.git
+ source = git+https://gitlab.com/eh5/libldac.git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 6bc19536f56c..d962b603cdd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: EHfive <eh5@sokka.cn>
pkgname=pulseaudio-modules-bt-git
-pkgver=r25.2d97ce7
+pkgver=r26.cc65a46
pkgrel=1
pkgdesc="PulseAudio Bluetooth modules with Sony LDAC Codec(A2DP Source) support"
arch=("i686" "x86_64" "armv7h")
url="https://github.com/EHfive/pulseaudio-modules-bt"
license=('GPL3')
depends=("pulseaudio>=12.0" "libpulse>=12.0" "bluez>=5.0" "bluez-libs>=5.0" "sbc")
-makedepends=("cmake>=3.0" "make" )
+makedepends=("cmake>=3.0" "make" "pkg-config")
provides=("pulseaudio-bluetooth")
conflicts=("pulseaudio-bluetooth")
replaces=("pulseaudio-bluetooth")
source=("git+https://github.com/EHfive/pulseaudio-modules-bt.git"
"git+https://github.com/pulseaudio/pulseaudio.git"
- "git+https://android.googlesource.com/platform/external/libldac.git")
-noextract=()
+ "git+https://gitlab.com/eh5/libldac.git")
+
md5sums=('SKIP' 'SKIP' 'SKIP')
pkgver() {
@@ -30,11 +30,10 @@ prepare() {
ln -sf -T "../pulseaudio" "pa"
ln -sf -T "../libldac" "libldac"
cd "pa"
- git checkout v12.2
+ git checkout v`pkg-config libpulse --modversion`
}
build() {
- export CFLAGS=''
cd "$srcdir/pulseaudio-modules-bt"
cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr .
make