summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2020-11-26 12:39:41 -0500
committerVincent Grande2020-11-26 12:39:41 -0500
commit33cfa6c21d487c0a40ba55f3ae0c345168ce3c0d (patch)
tree9f6ba7c366593d64bcfc425952cd7d4028182608
parentb52a9c96c638a07cbab41448cecbba8882861354 (diff)
downloadaur-33cfa6c21d487c0a40ba55f3ae0c345168ce3c0d.tar.gz
fix
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD34
2 files changed, 16 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef651fcf32ec..6c2a2c43afe7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,13 +17,9 @@ pkgbase = pulseaudio-nosystemd-minimal-git
depends = rtkit
depends = tdb
depends = orc
- depends = python-pyqt5
- depends = python-dbus
- depends = python-sip
depends = dconf
optdepends = alsa-plugins: ALSA support
optdepends = pulseaudio-alsa: ALSA configuration (recommended)
- optdepends = lirc-utils: infra-red support
options = !emptydirs
backup = etc/pulse/daemon.conf
backup = etc/pulse/default.pa
diff --git a/PKGBUILD b/PKGBUILD
index fc0e879188dd..ca2c93ebad7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,14 +16,12 @@ pkgrel=1
arch=(x86_64)
url="https://www.freedesktop.org/wiki/Software/PulseAudio/"
license=(GPL)
-depends=("libltdl" "rtkit" "tdb" "orc"
- python-{pyqt5,dbus,sip} dconf)
+depends=("libltdl" "rtkit" "tdb" "orc" "dconf")
makedepends=("git" "attr" "rtkit"
"tdb" "intltool"
"orc" "check" "meson")
optdepends=("alsa-plugins: ALSA support"
- "pulseaudio-alsa: ALSA configuration (recommended)"
- "lirc-utils: infra-red support")
+ "pulseaudio-alsa: ALSA configuration (recommended)")
backup=(etc/pulse/{daemon.conf,default.pa,system.pa,client.conf})
options=(!emptydirs)
source=("git+https://gitlab.freedesktop.org/pulseaudio/pulseaudio.git")
@@ -49,25 +47,25 @@ build() {
-D systemd=disabled \
-D man=false \
-D legacy-database-entry-format=false \
- -D asyncns=false \
- -D avahi=false \
+ -D asyncns=disabled \
+ -D avahi=disabled \
-D bluez5=false \
-D bluez5-native-headset=false \
-D bluez5-ofono-headset=false \
- -D dbus=false \
- -D fftw=false \
- -D glib=false \
- -D gsettings=false \
- -D gstreamer=false \
- -D gtk=false \
+ -D dbus=disabled \
+ -D fftw=disabled \
+ -D glib=disabled \
+ -D gsettings=disabled \
+ -D gstreamer=disabled \
+ -D gtk=disabled \
-D ipv6=false \
- -D jack=false \
- -D lirc=false \
- -D openssl=false \
- -D soxr=false \
- -D speex=false \
+ -D jack=disabled \
+ -D lirc=disabled \
+ -D openssl=disabled \
+ -D soxr=disabled \
+ -D speex=disabled \
-D adrian-aec=false \
- -D webrtc-aec=false
+ -D webrtc-aec=disabled
meson compile -C build
}