summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2021-01-23 15:12:01 +0100
committerGianluca Boiano2021-01-23 15:12:01 +0100
commit3b8413a047041d3b3d118015f657c040203d5381 (patch)
treeb954d0a43dd254d2b95c108f8ffe8b7cf8f92173
parent7f98ff3bca4204703af7d5bcc3891f1bccefcf0d (diff)
downloadaur-3b8413a047041d3b3d118015f657c040203d5381.tar.gz
pulseeffects-git: remove redundant build
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD26
2 files changed, 11 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 782ca928ae7b..dae27b2d7c87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pulseeffects-git
pkgdesc = Audio Effects for Pipewire applications
pkgver = 5.0.0.r2.g441ea8a0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/wwmm/pulseeffects
arch = x86_64
arch = i686
@@ -17,7 +17,7 @@ pkgbase = pulseeffects-git
makedepends = appstream-glib
makedepends = zam-plugins
makedepends = rubberband
- source = git+https://github.com/wwmm/pulseeffects.git
+ source = pulseeffects::git+https://github.com/wwmm/pulseeffects.git
sha512sums = SKIP
pkgname = pulseeffects-git
diff --git a/PKGBUILD b/PKGBUILD
index b034016f1c15..becefcb161fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,28 +6,24 @@
pkgbase=pulseeffects-git
pkgname=("${pkgbase}" "gst-plugins-${pkgbase}")
pkgver=5.0.0.r2.g441ea8a0
-pkgrel=2
+pkgrel=3
pkgdesc='Audio Effects for Pipewire applications'
arch=(x86_64 i686 arm armv6h armv7h aarch64)
url='https://github.com/wwmm/pulseeffects'
license=('GPL3')
makedepends=('meson' 'boost' 'git' 'itstool' 'appstream-glib'
'zam-plugins' 'rubberband')
-source=("git+https://github.com/wwmm/pulseeffects.git")
+source=("${pkgbase%%-git}::git+https://github.com/wwmm/pulseeffects.git")
sha512sums=('SKIP')
pkgver() {
- cd pulseeffects
+ cd "${pkgbase%%-git}"
printf "%s" "$(git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g')"
}
build() {
- mkdir -p pulseeffects/build
- cd pulseeffects/build
-
- arch-meson ..
-
- ninja
+ arch-meson ${pkgbase%%-git} build
+ meson compile -C build
}
package_pulseeffects-git() {
@@ -40,10 +36,8 @@ package_pulseeffects-git() {
conflicts=('pulseeffects')
provides=('pulseeffects')
- cd pulseeffects/build
-
- DESTDIR="${pkgdir}" ninja install
- rm -r "${pkgdir}/usr/lib"
+ DESTDIR="${pkgdir}" meson install -C build
+ mv "${pkgdir}/usr/lib" .
}
package_gst-plugins-pulseeffects-git() {
@@ -53,8 +47,6 @@ package_gst-plugins-pulseeffects-git() {
conflicts=('gst-plugins-pulseeffects')
provides=('gst-plugins-pulseeffects')
- cd pulseeffects/build
-
- DESTDIR="${pkgdir}" ninja install
- rm -rf "${pkgdir}"/usr/{bin,share}
+ install -d "${pkgdir}/usr"
+ mv lib "${pkgdir}/usr"
}