summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBleuzen2019-02-10 11:29:36 +0100
committerBleuzen2019-02-10 11:29:36 +0100
commit76ff953b837af21cd73ceec7589ab4a139284e22 (patch)
treece3b4a71135726a4d9d2bf09545b89f82a58c1cd
parent5ccce7a4443fec4ee405620e0b263f9fac24204e (diff)
downloadaur-76ff953b837af21cd73ceec7589ab4a139284e22.tar.gz
use git version in pkgver function and set arch to any
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b47ca9809f00..9cd01b3225d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = pulseeffects-git
pkgdesc = Audio Effects for Pulseaudio Applications
- pkgver = 20190209
+ pkgver = 4.4.7.r131.g58be1741
pkgrel = 1
url = https://github.com/wwmm/pulseeffects
- arch = x86_64
+ arch = any
license = GPL3
makedepends = meson
makedepends = boost
diff --git a/PKGBUILD b/PKGBUILD
index 494733b39ed6..d07329d6d0b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,10 @@
# Contributor: Wellington <wellingtonwallace@gmail.com>
pkgname=pulseeffects-git
-pkgver=20190209
+pkgver=4.4.7.r131.g58be1741
pkgrel=1
pkgdesc='Audio Effects for Pulseaudio Applications'
-arch=('x86_64')
+arch=('any')
url='https://github.com/wwmm/pulseeffects'
license=('GPL3')
depends=('gtk3' 'gtkmm3' 'glibmm' 'libpulse' 'gstreamer' 'gst-plugins-good' 'gst-plugins-bad'
@@ -22,6 +22,11 @@ conflicts=(pulseeffects)
provides=(pulseeffects)
sha512sums=('SKIP')
+pkgver() {
+ cd pulseeffects
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
mkdir -p pulseeffects/build
cd pulseeffects/build