summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-01-23 10:15:55 -0700
committerMark Wagie2021-01-23 10:15:55 -0700
commit1f15311ef3fd0295b8432ecb1d41fc033a490199 (patch)
tree0fb0dbf9df93b04c6b1e1bb0f9f1a0c034c0ede2
downloadaur-1f15311ef3fd0295b8432ecb1d41fc033a490199.tar.gz
initial commit
-rw-r--r--.SRCINFO79
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD69
3 files changed, 155 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51639efff119
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,79 @@
+pkgbase = pulseeffects-legacy-git
+ pkgdesc = Audio Effects for Pulseaudio applications
+ pkgver = 4.8.4.r0.g4e7532f7
+ pkgrel = 1
+ url = https://github.com/wwmm/pulseeffects
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ makedepends = boost
+ makedepends = itstool
+ makedepends = appstream-glib
+ makedepends = zam-plugins
+ makedepends = rubberband
+ makedepends = librnnoise
+ depends = gtk3
+ depends = gtkmm3
+ depends = glibmm
+ depends = pulseaudio
+ depends = gstreamer
+ depends = gst-plugin-gtk
+ depends = gst-plugins-bad
+ depends = lilv
+ depends = boost-libs
+ depends = libsigc++
+ depends = libsndfile
+ depends = libsamplerate
+ depends = zita-convolver
+ depends = libebur128
+ source = git+https://github.com/wwmm/pulseeffects.git#branch=pulseaudio-legacy
+ sha256sums = SKIP
+
+pkgname = pulseeffects-legacy-git
+ depends = gtk3
+ depends = gtkmm3
+ depends = glibmm
+ depends = pulseaudio
+ depends = gstreamer
+ depends = gst-plugin-gtk
+ depends = gst-plugins-bad
+ depends = lilv
+ depends = boost-libs
+ depends = libsigc++
+ depends = gst-plugins-pulseeffects-legacy
+ optdepends = calf: limiter, compressor exciter, bass enhancer and others
+ optdepends = lsp-plugins: equalizer, delay
+ optdepends = rubberband: pitch shifting
+ optdepends = zam-plugins: maximizer
+ optdepends = yelp: in-app help
+ provides = pulseeffects-legacy
+ provides = pulseeffects
+ conflicts = pulseeffects-legacy
+ conflicts = pulseeffects
+
+pkgname = gst-plugins-pulseeffects-legacy-git
+ pkgdesc = Audio Effects for Pulseaudio applications - gstreamer plugins
+ depends = gst-plugins-base
+ depends = gstreamer
+ depends = libebur128
+ depends = librnnoise
+ depends = libsamplerate
+ depends = libsndfile
+ depends = zita-convolver
+ provides = gst-plugins-pulseeffects-legacy
+ provides = gst-plugins-pulseeffects
+ provides = libgstpernnoise.so
+ provides = libgstpecrystalizer.so
+ provides = libgstpecrystalizer.so
+ provides = libgstpeconvolver.so
+ provides = libgstpeautogain.so
+ provides = libgstpeadapter.so
+ conflicts = gst-plugins-pulseeffects-legacy
+ conflicts = gst-plugins-pulseeffects
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d6daac4f9f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,69 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: robertfoster
+# Contributor: Bleuzen <supgesu@gmail.com>
+# Contributor: Filipe LaĆ­ns (FFY00) <lains@archlinux.org>
+# Contributor: Wellington <wellingtonwallace@gmail.com>
+
+# This is the last release supporting Pulseaudio. The following PulseEffects
+# releases will be based on the new Pipewire multimedia server and only fixes
+# to critical bugs will be backported to the legacy pulseaudio branch
+
+pkgname=('pulseeffects-legacy-git' 'gst-plugins-pulseeffects-legacy-git')
+pkgbase=pulseeffects-legacy-git
+pkgver=4.8.4.r0.g4e7532f7
+pkgrel=1
+pkgdesc='Audio Effects for Pulseaudio applications'
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/wwmm/pulseeffects"
+license=('GPL3')
+depends=('gtk3' 'gtkmm3' 'glibmm' 'pulseaudio' 'gstreamer' 'gst-plugin-gtk'
+ 'gst-plugins-bad' 'lilv' 'boost-libs' 'libsigc++' 'libsndfile'
+ 'libsamplerate' 'zita-convolver' 'libebur128')
+makedepends=('git' 'meson' 'boost' 'itstool' 'appstream-glib' 'zam-plugins'
+ 'rubberband' 'librnnoise')
+source=('git+https://github.com/wwmm/pulseeffects.git#branch=pulseaudio-legacy')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/pulseeffects"
+ printf "%s" "$(git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g')"
+}
+
+build() {
+ arch-meson pulseeffects build
+ meson compile -C build
+}
+
+package_pulseeffects-legacy-git() {
+ depends=('gtk3' 'gtkmm3' 'glibmm' 'pulseaudio' 'gstreamer' 'gst-plugin-gtk'
+ 'gst-plugins-bad' 'lilv' 'boost-libs' 'libsigc++'
+ 'gst-plugins-pulseeffects-legacy')
+ optdepends=('calf: limiter, compressor exciter, bass enhancer and others'
+ 'lsp-plugins: equalizer, delay'
+ 'rubberband: pitch shifting'
+ 'zam-plugins: maximizer'
+ 'yelp: in-app help')
+ provides=("${pkgname%-git}" 'pulseeffects')
+ conflicts=("${pkgname%-git}" 'pulseeffects')
+
+ DESTDIR="$pkgdir" meson install -C build
+ mv "$pkgdir/usr/lib" .
+}
+
+package_gst-plugins-pulseeffects-legacy-git() {
+ pkgdesc+=" - gstreamer plugins"
+ depends=('gst-plugins-base' 'gstreamer' 'libebur128' 'librnnoise'
+ 'libsamplerate' 'libsndfile' 'zita-convolver')
+ provides=("${pkgname%-git}"
+ 'gst-plugins-pulseeffects'
+ 'libgstpernnoise.so'
+ 'libgstpecrystalizer.so'
+ 'libgstpecrystalizer.so'
+ 'libgstpeconvolver.so'
+ 'libgstpeautogain.so'
+ 'libgstpeadapter.so')
+ conflicts=("${pkgname%-git}" 'gst-plugins-pulseeffects')
+
+ install -d "$pkgdir/usr"
+ mv lib "$pkgdir/usr"
+}