summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Ortiz Manero2021-05-15 12:23:30 +0200
committerMario Ortiz Manero2021-05-15 12:23:30 +0200
commit8a360be70af04c9e74a735a9cdcc1875c2c56053 (patch)
treebcd225c4cbf18d865adf32ea2d7c3ef4677c40f3
downloadaur-8a360be70af04c9e74a735a9cdcc1875c2c56053.tar.gz
First release!
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93214378d3ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pulseeffects-presets
+ pkgdesc = Control PulseAudio from the polybar status bar
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/marioortizmanero/polybar-pulseeffects-presets
+ arch = any
+ license = custom:MIT
+ depends = bash
+ depends = pulseeffects
+ source = https://github.com/marioortizmanero/polybar-pulseeffects-presets/archive/v0.2.1.tar.gz
+ md5sums = e9442386844149553773db654221af76
+
+pkgname = pulseeffects-presets
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c70a18be29d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mario Ortiz Manero <marioortizmanero@gmail.com>
+# shellcheck disable=SC2034,SC2154
+pkgname=pulseeffects-presets
+_reponame="polybar-$pkgname" # expected to change
+pkgver=0.2.1
+pkgrel=1
+pkgdesc='Control PulseAudio from the polybar status bar'
+url="https://github.com/marioortizmanero/${_reponame}"
+license=('custom:MIT')
+source=("${url}/archive/v${pkgver}.tar.gz")
+md5sums=('e9442386844149553773db654221af76')
+arch=('any')
+depends=(
+ 'bash'
+ 'pulseeffects'
+)
+optdepends=(
+)
+conflicts=(
+)
+
+package() {
+ set -e
+ cd "${_reponame}-$pkgver"
+
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ mkdir -p "$pkgdir/usr/bin"
+ install -D -m755 "./pulseeffects-presets.bash" "$pkgdir/usr/bin/$pkgname"
+}