summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Talker2016-02-27 17:38:15 +0300
committerAlex Talker2016-02-27 17:41:45 +0300
commitaeced125c2fcb5c12ccd3356fbb8802fc063abbf (patch)
tree09a618af962319153df831400f933b6e40637ee8
parent3fb1dd1d4221d0f05e7581cdd885ec768af201b4 (diff)
downloadaur-aeced125c2fcb5c12ccd3356fbb8802fc063abbf.tar.gz
Clean ups and new epoch
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD48
3 files changed, 28 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b64f763ac3f1..34fbd691cf33 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Feb 27 14:41:21 UTC 2016
pkgbase = pulsemixer-git
- pkgdesc = cli and curses mixer for pulseaudio
- pkgver = r35.c7817ad
+ pkgdesc = cli and curses mixer for pulseaudio. Git version
+ pkgver = 56.f088a91
pkgrel = 1
+ epoch = 1
url = https://github.com/GeorgeFilipkin/pulsemixer
arch = any
- license = MIT
+ license = GPL3
makedepends = git
depends = python
depends = pulseaudio
+ conflicts = pulsemixer
+ replaces = pulsemixer
+ source = git://github.com/GeorgeFilipkin/pulsemixer.git
+ md5sums = SKIP
pkgname = pulsemixer-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..355164c12651
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*/
diff --git a/PKGBUILD b/PKGBUILD
index c8e95c881b76..75cf858e0464 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,28 @@
-# Maintainer: Jeff Parent <jecxjo@sdf.lonestar.org>
-pkgname=pulsemixer-git
-pkgver=r35.c7817ad
+# Maintainer: Alex Talker < alextalker at openmailbox dot org >
+# Previous maintainer: Jeff Parent <jecxjo@sdf.lonestar.org>
+_gitbase=pulsemixer
+pkgname=${_gitbase}-git
+pkgver=56.f088a91
pkgrel=1
-pkgdesc="cli and curses mixer for pulseaudio"
-arch=(any)
-url="https://github.com/GeorgeFilipkin/pulsemixer"
-license=('MIT')
+epoch=1
+pkgdesc="cli and curses mixer for pulseaudio. Git version"
+arch=('any')
+url="https://github.com/GeorgeFilipkin/${_gitbase}"
+license=('GPL3')
depends=('python' 'pulseaudio')
makedepends=('git')
-
-_gitroot=https://github.com/GeorgeFilipkin/pulsemixer.git
-_gitname=pulsemixer
+conflicts=($_gitbase)
+replaces=($_gitbase)
+source=("git://github.com/GeorgeFilipkin/${_gitbase}.git")
+md5sums=('SKIP')
pkgver() {
- cd "$_gitname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
-build() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
-
- if [[ -d "$_gitname" ]]; then
- cd "$_gitname" && git pull origin
- msg "The local files are updated."
- else
- git clone "$_gitroot" "$_gitname"
- fi
-
- msg "GIT checkout done or server timeout"
- msg "Starting build..."
-
- rm -rf "$srcdir/$_gitname-build"
- git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$_gitbase"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
package() {
- cd "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitbase"
install -m 755 -d "$pkgdir/usr/bin"
install -m 755 pulsemixer "$pkgdir/usr/bin/"
}