summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMathieu Westphal2017-05-25 18:46:20 +0200
committerMathieu Westphal2017-05-25 18:48:18 +0200
commit6d09de2f975f17c8510337da575c8402ed0e3bed (patch)
tree8db099cbb102a8b8fe1c02e00a489e0a15f787d1
downloadaur-6d09de2f975f17c8510337da575c8402ed0e3bed.tar.gz
Initial Commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b7832bda71fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = pulsenomore
+ pkgdesc = Run Executable without Pulseaudio correctly
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://bugs.kerbalspaceprogram.com/issues/7515#note-28
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = https://raw.githubusercontent.com/mwestphal/pulsenomore/master/pulsenomore.c
+ sha256sums = b55398ee95f9f65eeef91c5df79d12a3bdbe2e6e8e75bc46c058c330cac903ca
+
+pkgname = pulsenomore
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8efb8e4b3ec1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+pkgname=pulsenomore
+pkgver=0.1
+pkgrel=1
+pkgdesc="Run Executable without Pulseaudio correctly"
+license=('GPL')
+arch=('i686' 'x86_64')
+url="http://bugs.kerbalspaceprogram.com/issues/7515#note-28"
+source=("https://raw.githubusercontent.com/mwestphal/pulsenomore/master/$pkgname.c")
+sha256sums=('b55398ee95f9f65eeef91c5df79d12a3bdbe2e6e8e75bc46c058c330cac903ca')
+
+build() {
+ gcc -std=gnu99 -O2 -o $pkgname $pkgname.c -ldl
+}
+
+package() {
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+}
+