summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTun Win Naing2021-09-11 17:17:07 +0630
committerTun Win Naing2021-09-11 17:17:07 +0630
commit9ed0c1f9a64fa99f764b1235dc16177da79f9ee9 (patch)
tree7c25d0a045130bdf814cb3b3f6f93afc030bb9aa
downloadaur-9ed0c1f9a64fa99f764b1235dc16177da79f9ee9.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD37
-rw-r--r--system.service9
-rw-r--r--user.service9
5 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..561974419291
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = puma-dev-bin
+ pkgdesc = A fast, zero-config development server for macOS and Linux
+ pkgver = 0.16.2
+ pkgrel = 1
+ url = https://github.com/puma/puma-dev/
+ arch = x86_64
+ license = BSD
+ optdepends = authbind: to bind 80/443 ports
+ optdepends = dev-tld-resolver: to resolve .test domain
+ optdepends = p11-kit: for SSL support
+ provides = puma-dev
+ source = https://github.com/puma/puma-dev/releases/download/v0.16.2/puma-dev-0.16.2-linux-amd64.tar.gz
+ source = system.service
+ source = user.service
+ source = https://raw.githubusercontent.com/puma/puma-dev/v0.16.2/LICENSE
+ md5sums = f6dd065d5cbfe23ab2b6c93c3498d7e6
+ md5sums = 9f88d670d220d36ee75b97c496c7970d
+ md5sums = f0906043620889a1903b5f69c349029f
+ md5sums = SKIP
+
+pkgname = puma-dev-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9d6e73a24c48
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src
+pkg
+*.tar.gz
+*.pkg.tar.zst
+LICENSE
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4227d00ed4f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Tun Win Naing <twnaing(at)outlook(dot)com>
+pkgname=puma-dev-bin
+_pkgname=puma-dev
+pkgver=0.16.2
+pkgrel=1
+pkgdesc="A fast, zero-config development server for macOS and Linux"
+arch=('x86_64')
+url="https://github.com/puma/puma-dev/"
+license=(BSD)
+optdepends=('authbind: to bind 80/443 ports'
+ 'dev-tld-resolver: to resolve .test domain'
+ 'p11-kit: for SSL support')
+provides=('puma-dev')
+source=("https://github.com/puma/puma-dev/releases/download/v${pkgver//_/-}/puma-dev-${pkgver//_/-}-linux-amd64.tar.gz"
+ 'system.service'
+ 'user.service'
+ "https://raw.githubusercontent.com/puma/puma-dev/v${pkgver//_/-}/LICENSE")
+md5sums=('f6dd065d5cbfe23ab2b6c93c3498d7e6'
+ '9f88d670d220d36ee75b97c496c7970d'
+ 'f0906043620889a1903b5f69c349029f'
+ 'SKIP')
+
+package(){
+ cd "$srcdir"
+
+ install -d "${pkgdir}"/usr/bin
+ install -Dm755 puma-dev "${pkgdir}"/usr/bin/puma-dev
+
+ install -d "${pkgdir}"/usr/lib/systemd/system
+ install -Dm644 "${srcdir}"/system.service "${pkgdir}"/usr/lib/systemd/system/puma-dev.service
+ install -Dm644 "${srcdir}"/user.service "${pkgdir}"/usr/lib/systemd/user/puma-dev.service
+
+ install -d "${pkgdir}"/usr/share/licenses/puma-dev/
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/puma-dev/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/system.service b/system.service
new file mode 100644
index 000000000000..9df5c4edb76c
--- /dev/null
+++ b/system.service
@@ -0,0 +1,9 @@
+[Unit]
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/puma-dev -sysbind
+Restart=on-failure
+
+[Install]
+WantedBy=multi-user.target
diff --git a/user.service b/user.service
new file mode 100644
index 000000000000..d7003d3ec59d
--- /dev/null
+++ b/user.service
@@ -0,0 +1,9 @@
+[Unit]
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/puma-dev
+Restart=on-failure
+
+[Install]
+WantedBy=default.target