summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmin Vakil2021-09-07 10:52:11 +0430
committerAmin Vakil2021-09-07 10:52:11 +0430
commit3a1c738b7feb5b25ca1ad70a8b36d5dcf8fa8321 (patch)
treef8e2b52977c35f161f57a93a396a09f8d251a1ec
downloadaur-3a1c738b7feb5b25ca1ad70a8b36d5dcf8fa8321.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51618dd87296
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pumba-bin
+ pkgdesc = Chaos testing, network emulation and stress testing tool for containers
+ pkgver = 0.7.8
+ pkgrel = 1
+ url = https://github.com/alexei-led/pumba
+ arch = aarch64
+ arch = x86_64
+ license = Apache
+ provides = pumba
+ conflicts = pumba
+ source_aarch64 = pumba-linux-aarch64::https://github.com/alexei-led/pumba/releases/download/0.7.8/pumba_linux_arm64
+ sha256sums_aarch64 = 1e53a980810db865eecbe3ff475089bac03df45a8b016653b8e8a0d458d03860
+ source_x86_64 = pumba-linux-x86_64::https://github.com/alexei-led/pumba/releases/download/0.7.8/pumba_linux_amd64
+ sha256sums_x86_64 = 802e407e7fbb8f5c0bab968b52062aea27a2c3aa350c08dacc37b4f4246e55bd
+
+pkgname = pumba-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de4b0dc055e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Amin Vakil <info AT aminvakil DOT com>
+
+_pkgname=pumba
+pkgname=pumba-bin
+pkgver=0.7.8
+pkgrel=1
+pkgdesc="Chaos testing, network emulation and stress testing tool for containers "
+arch=('aarch64' 'x86_64')
+url="https://github.com/alexei-led/pumba"
+license=('Apache')
+conflicts=('pumba')
+provides=('pumba')
+
+source_x86_64=("${_pkgname}-linux-x86_64::$url/releases/download/$pkgver/${_pkgname}_linux_amd64")
+source_aarch64=("${_pkgname}-linux-aarch64::$url/releases/download/$pkgver/${_pkgname}_linux_arm64")
+
+sha256sums_aarch64=('1e53a980810db865eecbe3ff475089bac03df45a8b016653b8e8a0d458d03860')
+sha256sums_x86_64=('802e407e7fbb8f5c0bab968b52062aea27a2c3aa350c08dacc37b4f4246e55bd')
+
+package() {
+ mkdir -p ${pkgdir}/usr/bin
+ install ${srcdir}/${_pkgname}-linux-${CARCH} ${pkgdir}/usr/bin/${_pkgname}
+}
+