summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302017-08-11 12:47:36 +0200
committerM0Rf302017-08-11 12:47:36 +0200
commit57a0154e800836d6f8cbe2e33e3388d4920924ce (patch)
tree23eb61ab12f4184a63855907827b2151d8c7ac0d
parent27cff1772ea98c8de2cca1b09f2637f6b0586ab7 (diff)
downloadaur-57a0154e800836d6f8cbe2e33e3388d4920924ce.tar.gz
pump.io: 4.1.2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD34
-rw-r--r--pump.io.install11
3 files changed, 20 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 386d6521cb76..577b8aae33a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
# Generated by mksrcinfo v8
-# Sun May 28 13:16:54 UTC 2017
+# Fri Aug 11 10:47:09 UTC 2017
pkgbase = pump.io
pkgdesc = This is pump.io. It's a stream server that does most of what people really want from a social network
- pkgver = 4.0.1
+ pkgver = 4.1.2
pkgrel = 1
url = http://pump.io
install = pump.io.install
arch = i686
arch = x86_64
license = Apache
- depends = nodejs6-bin
+ depends = nodejs-lts-boron
depends = graphicsmagick
optdepends = mongodb
optdepends = redis
@@ -17,8 +17,8 @@ pkgbase = pump.io
conflicts = pumpio-git
conflicts = pumpio
backup = etc/webapps/pump.io/pump.io.json
- source = https://github.com/pump-io/pump.io/archive/v4.0.1.tar.gz
- md5sums = 1125fd041dc6330fe1561b2fb39dbc74
+ source = https://github.com/pump-io/pump.io/archive/v4.1.2.tar.gz
+ md5sums = 27235551c29b90240cc98ce3604e34e2
pkgname = pump.io
diff --git a/PKGBUILD b/PKGBUILD
index 94639e4cfe15..a47ee1a35abd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: M0Rf30
pkgname=pump.io
-pkgver=4.0.1
+pkgver=4.1.2
pkgrel=1
pkgdesc="This is pump.io. It's a stream server that does most of what people really want from a social network"
url='http://pump.io'
license=('Apache')
arch=('i686' 'x86_64')
-depends=('nodejs6-bin' 'graphicsmagick')
+depends=('nodejs-lts-boron' 'graphicsmagick')
optdepends=('mongodb' 'redis')
provides=('pumpio')
conflicts=('pumpio-git' 'pumpio')
@@ -15,23 +15,17 @@ install=${pkgname}.install
backup=(etc/webapps/$pkgname/$pkgname.json)
source=(https://github.com/pump-io/pump.io/archive/v$pkgver.tar.gz)
-build() {
- cd $srcdir/$pkgname-$pkgver
- npm install
- npm install bunyan
- npm install databank-mongodb
- npm install databank-redis
- npm prune --production
-}
-
package() {
- cd $srcdir/$pkgname-$pkgver
- mkdir -p $pkgdir/usr/share/webapps/
- mkdir -p $pkgdir/usr/lib/systemd/system/
- mkdir -p $pkgdir/etc/webapps/$pkgname/
- cp -r ../$pkgname-$pkgver $pkgdir/usr/share/webapps/$pkgname
- cp $pkgname.json.sample $pkgdir/etc/webapps/$pkgname/$pkgname.json
- cp $pkgname\@.service $pkgdir/usr/lib/systemd/system/
- cp -r bin $pkgdir/usr
+cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $pkgname@$pkgver
+
+msg2 "Installing systemd service"
+ install -Dm755 -d "$srcdir/$pkgname-$pkgver/$pkgname\@.service" "${pkgdir}/usr/lib/systemd/system/"
+ install -Dm755 -d "$pkgname.json.sample" "$pkgdir/etc/$pkgname.json"
+ rm -rf $pkgdir/usr/etc
}
-md5sums=('1125fd041dc6330fe1561b2fb39dbc74')
+
+md5sums=('27235551c29b90240cc98ce3604e34e2')
diff --git a/pump.io.install b/pump.io.install
index f647bee3691a..99fcd0ca28e6 100644
--- a/pump.io.install
+++ b/pump.io.install
@@ -1,14 +1,5 @@
-pumpuser=pump
-pumphome=/usr/share/webapps/pump.io
-
-_chown() {
- chown -R $pumpuser:$pumpuser $pumphome
-}
-
post_install() {
- getent passwd $pumpuser &> /dev/null || useradd -r -d $pumphome -s /bin/bash $pumpuser
- _chown
- echo 'Edit the file /etc/webapps/pump.io/pump.io.json as needed. Please look over the documentation at http://pump.io/#configuration'
+ echo 'Edit the file /etc/pump.io.json as needed. Please look over the documentation at http://pump.io/#configuration'
}
post_upgrade() {