summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302017-01-30 17:31:25 +0100
committerM0Rf302017-01-30 17:31:25 +0100
commit9eea601d8a84800fb812b2f6dc33384d1c1c7a75 (patch)
tree54d733bf77c0abad3627d51c56d70f1ba7e01102
parent7748ec805dc3c8ac145be71edf85cd91557fb3d8 (diff)
downloadaur-9eea601d8a84800fb812b2f6dc33384d1c1c7a75.tar.gz
2.1.1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
-rw-r--r--pump.io25
-rw-r--r--pump.io.json16
-rw-r--r--pump.io.service15
5 files changed, 16 insertions, 84 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 594e62d9592d..aedf70a69ffd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
# Generated by mksrcinfo v8
-# Wed Sep 21 18:15:41 UTC 2016
+# Mon Jan 30 16:31:13 UTC 2017
pkgbase = pump.io
pkgdesc = This is pump.io. It's a stream server that does most of what people really want from a social network
- pkgver = 1.0.0
+ pkgver = 2.1.1
pkgrel = 1
url = http://pump.io
install = pump.io.install
arch = i686
arch = x86_64
license = Apache
- depends = nodejs
+ depends = nodejs6-bin
depends = graphicsmagick
optdepends = mongodb
optdepends = redis
@@ -17,14 +17,8 @@ pkgbase = pump.io
conflicts = pumpio-git
conflicts = pumpio
backup = etc/webapps/pump.io/pump.io.json
- source = https://github.com/e14n/pump.io/archive/v1.0.0.tar.gz
- source = pump.io.service
- source = pump.io.json
- source = pump.io
- md5sums = 9ceb4f24a99f0f10b7313275d9e4a75b
- md5sums = dcfd7c74792755996d0d9589bfaf6747
- md5sums = d072eb2d992586e013c06c64786fc4ca
- md5sums = 067b3c2fee9cef8a596bac9e9d89ae75
+ source = https://github.com/e14n/pump.io/archive/v2.1.1.tar.gz
+ md5sums = 5ec91d6963b8db05f33c72f9e7d03813
pkgname = pump.io
diff --git a/PKGBUILD b/PKGBUILD
index ca44c617343b..045965f6cddf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,38 @@
# Maintainer: M0Rf30
pkgname=pump.io
-pkgver=1.0.0
+pkgver=2.1.1
pkgrel=1
pkgdesc="This is pump.io. It's a stream server that does most of what people really want from a social network"
url='http://pump.io'
license=('Apache')
arch=('i686' 'x86_64')
-depends=('nodejs' 'graphicsmagick')
+depends=('nodejs6-bin' 'graphicsmagick')
optdepends=('mongodb' 'redis')
provides=('pumpio')
conflicts=('pumpio-git' 'pumpio')
install=${pkgname}.install
backup=(etc/webapps/$pkgname/$pkgname.json)
-source=(https://github.com/e14n/pump.io/archive/v$pkgver.tar.gz
- $pkgname.service
- $pkgname.json
- $pkgname)
-
+source=(https://github.com/e14n/pump.io/archive/v$pkgver.tar.gz)
build() {
cd $srcdir/$pkgname-$pkgver
- export PYTHON=/usr/bin/python2
+# export PYTHON=/usr/bin/python2
npm install
+ npm install bunyan
npm install databank-mongodb
npm install databank-redis
npm prune --production
}
package() {
- cd $srcdir
+ cd $srcdir/$pkgname-$pkgver
mkdir -p $pkgdir/usr/share/webapps/
mkdir -p $pkgdir/usr/lib/systemd/system/
mkdir -p $pkgdir/etc/webapps/$pkgname/
- install -Dm755 pump.io $pkgdir/usr/bin/pump.io
- cp -r $pkgname-$pkgver $pkgdir/usr/share/webapps/$pkgname
- cp $pkgname.json $pkgdir/etc/webapps/$pkgname/$pkgname.json
- cp $pkgname.service $pkgdir/usr/lib/systemd/system/
+ cp -r ../$pkgname-$pkgver $pkgdir/usr/share/webapps/$pkgname
+ cp $pkgname.json.sample $pkgdir/etc/webapps/$pkgname/$pkgname.json
+ cp $pkgname.service.sample $pkgdir/usr/lib/systemd/system/$pkgname.service
+ cp -r bin $pkgdir/usr
}
-md5sums=('9ceb4f24a99f0f10b7313275d9e4a75b'
- 'dcfd7c74792755996d0d9589bfaf6747'
- 'd072eb2d992586e013c06c64786fc4ca'
- '067b3c2fee9cef8a596bac9e9d89ae75')
+md5sums=('5ec91d6963b8db05f33c72f9e7d03813')
diff --git a/pump.io b/pump.io
deleted file mode 100644
index 81fd9abaed8d..000000000000
--- a/pump.io
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/bin/bash
-
-WorkingDirectory=/usr/share/webapps/pump.io
-cd $WorkingDirectory
-# depending on parameter -- startup, shutdown, restart
-# of the instance and listener or usage display
-
-case "$1" in
- start)
- # Oracle listener and instance startup
- node ./bin/pump -c /etc/webapps/pump.io/pump.io.json start &
- ;;
- stop)
- # Oracle listener and instance shutdown
- node ./bin/pump -c /etc/webapps/pump.io/pump.io.json stop
- ;;
- restart)
- $0 stop
- $0 start
- ;;
- *)
- echo "Usage: $0 start|stop|restart"
- exit 1
-esac
-exit 0 \ No newline at end of file
diff --git a/pump.io.json b/pump.io.json
deleted file mode 100644
index c58b2f7d5a1c..000000000000
--- a/pump.io.json
+++ /dev/null
@@ -1,16 +0,0 @@
-{
- "driver": "memory",
- "secret": "my dog has fleas",
- "noweb": false,
- "site": "Awesome Sauce",
- "owner": "Awesome Inc.",
- "ownerURL": "http://example.com/",
- "port": 8000,
- "hostname": "localhost",
- "address": "localhost",
- "nologger": false,
- "serverUser": "pump",
- "uploaddir": "/tmp/pump.io/uploads",
- "debugClient": false,
- "firehose": "ofirehose.example"
-}
diff --git a/pump.io.service b/pump.io.service
deleted file mode 100644
index 5a90e8d404a0..000000000000
--- a/pump.io.service
+++ /dev/null
@@ -1,15 +0,0 @@
-[Unit]
-Description=Pump.io Social Server
-After=network.target
-
-[Service]
-Type=forking
-User=pump
-Group=pump
-ExecStart=/usr/bin/pump.io start
-ExecStop=/usr/bin/pump.io stop
-Restart=always
-SyslogIdentifier=pump.io
-
-[Install]
-WantedBy=multi-user.target