summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302018-08-03 12:13:47 +0200
committerM0Rf302018-08-03 12:13:47 +0200
commitfd752e7290c183c68ac8b9af2c5a91c05f21621e (patch)
tree07c7e9b49ace3af8706c1880be73d802426650d5
parenta9af2225c98837b6a26717e2b114d138e66b8287 (diff)
downloadaur-fd752e7290c183c68ac8b9af2c5a91c05f21621e.tar.gz
pump.io: 5.1.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 577b8aae33a8..c90a225b867b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
-# Generated by mksrcinfo v8
-# Fri Aug 11 10:47:09 UTC 2017
pkgbase = pump.io
- pkgdesc = This is pump.io. It's a stream server that does most of what people really want from a social network
- pkgver = 4.1.2
+ pkgdesc = A stream server that does most of what people really want from a social network
+ pkgver = 5.1.1
pkgrel = 1
url = http://pump.io
install = pump.io.install
arch = i686
arch = x86_64
license = Apache
- depends = nodejs-lts-boron
+ depends = nodejs
depends = graphicsmagick
optdepends = mongodb
optdepends = redis
@@ -17,8 +15,8 @@ pkgbase = pump.io
conflicts = pumpio-git
conflicts = pumpio
backup = etc/webapps/pump.io/pump.io.json
- source = https://github.com/pump-io/pump.io/archive/v4.1.2.tar.gz
- md5sums = 27235551c29b90240cc98ce3604e34e2
+ source = https://github.com/pump-io/pump.io/archive/v5.1.1.tar.gz
+ md5sums = 8ecae3256a522f91ad3328ce3181c13f
pkgname = pump.io
diff --git a/PKGBUILD b/PKGBUILD
index 30fd7f9d3b0e..f8584ab92a7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: robertfoster
pkgname=pump.io
-pkgver=4.1.2
+pkgver=5.1.1
pkgrel=1
-pkgdesc="This is pump.io. It's a stream server that does most of what people really want from a social network"
+pkgdesc="A stream server that does most of what people really want from a social network"
url='http://pump.io'
license=('Apache')
arch=('i686' 'x86_64')
-depends=('nodejs-lts-boron' 'graphicsmagick')
+depends=('nodejs' 'graphicsmagick')
optdepends=('mongodb' 'redis')
provides=('pumpio')
conflicts=('pumpio-git' 'pumpio')
@@ -20,12 +20,13 @@ cd $srcdir
local _npmdir="$pkgdir/usr/lib/node_modules/"
mkdir -p $_npmdir
cd $_npmdir
- npm install -g --prefix "$pkgdir/usr" $pkgname@$pkgver
+ npm install -g --prefix "$pkgdir/usr" $pkgname@$pkgver
+ npm prune --production
msg2 "Installing systemd service"
- install -Dm755 -d "$srcdir/$pkgname-$pkgver/$pkgname\@.service" "${pkgdir}/usr/lib/systemd/system/"
+ install -Dm644 "$srcdir/$pkgname-$pkgver/$pkgname@.service" "$pkgdir/usr/lib/systemd/system/$pkgname@.service"
install -Dm755 -d "$pkgname.json.sample" "$pkgdir/etc/$pkgname.json"
rm -rf $pkgdir/usr/etc
}
-md5sums=('27235551c29b90240cc98ce3604e34e2')
+md5sums=('8ecae3256a522f91ad3328ce3181c13f')