summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjrobb2015-09-04 07:02:52 -0400
committerjrobb2015-09-04 07:02:52 -0400
commita16cba961bfde065183ceb49152a96873461a0ba (patch)
tree7292e22823f81006c80aa02d78a56f7e131862f4
parentd3494c0dc3f73e5e324ed9db6600143d27f9c08b (diff)
downloadaur-a16cba961bfde065183ceb49152a96873461a0ba.tar.gz
fixed typeos in git clone command
-rwxr-xr-xPKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 08dc303d0d79..168f317d5809 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# thanks, speps!
pkgname=pumpa-git
pkgver=git
-pkgrel=2
+pkgrel=3
pkgdesc="A simple pump.io client written in C++ and Qt, git version"
arch=('i686' 'x86_64')
url="https://pumpa.branchable.com/"
@@ -13,7 +13,7 @@ install="$pkgname.install"
source=("$pkgname.desktop")
md5sums=('SKIP')
_appname=pumpa
-_gitRepo=${_appname}.branchable.com
+_gitRepo="$_appname.branchable.com"
prepare() {
cd ${srcdir}
@@ -23,11 +23,12 @@ prepare() {
#check if the clone directory already exists:
if [ ! -d ./${_gitRepo} ]; then
msg "repo doesn't exist-- cloning..."
- git clone git://${_gitRepo}
+ msg ${_gitRepo}
+ git clone git://${_gitRepo}/ ./${_appname}
echo "clone" > ${_statusfile}
else
msg "git pull-ing..."
- cd ${_gitRepo}
+ cd ${_appname}
git pull origin master > ${_statusfile}
fi
@@ -43,7 +44,7 @@ build() {
# msg "already up-to-date"
#else
msg "Starting make..."
- cd ${_gitRepo}
+ cd ${_appname}
# icon path fix
sed -i 's|/.*/||' ${_appname}.desktop